./sysutils/xenkernel45, Xen 4.5.x Kernel

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.5.5, Package name: xenkernel45-4.5.5, Maintainer: pkgsrc-users

Xen is a virtual machine monitor which supports running multiple
guests operating systems on a single machine. Guest OSes (also
called "domains") require a modified kernel which supports Xen
hypercalls in replacement to access to the physical hardware. At
boot, the xen kernel is loaded along with the guest kernel for the
first domain (called domain0). domain0 has privileges to access
the physical hardware (PCI and ISA devices), administrate other
domains and provide virtual devices (disks and network) to other
domains.

This package contains the 4.5 Xen4 kernel itself. PCI passthrough is
not supported. PAE is mandatory; on i386 one must use XEN3PAE_DOM[0U].


Required to build:
[lang/python27]

Master sites:

SHA1: 4073d411c72d3298baacfc15577b92b9ae577073
RMD160: 34132ab04752dc594fbdc1404c95f402b7bbbe39
Filesize: 17995.009 KB

Version history: (Expand)


CVS history: (Expand)


   2016-09-21 19:03:38 by Manuel Bouyer | Files touched by this commit (20) | Package removed
Log message:
Update xenkernel45 and xentools45 to 4.5.5.
Changes since 4.5.3: mostly bugfixes, including fixes for
security issues XSA-172, XSA-173, XSA-175, XSA-176, XSA-178, XSA-179, XSA-180,
XSA-181, XSA-182, XSA-183, XSA-184, XSA-185, XSA-186 and XSA-187.
All but XSA-175 were already fixed in pkgsrc.
Complete list of changes and links to the XSA advisories:
https://www.xenproject.org/downloads/xe … n-455.html
   2016-09-08 17:44:07 by Manuel Bouyer | Files touched by this commit (14) | Package updated
Log message:
Apply upstream patches for:
XSA-185: x86: Disallow L3 recursive pagetable for 32-bit PV guests
XSA-186: x86: Mishandling of instruction pointer truncation during emulation
XSA-187: x86 HVM: Overflow of sh_ctxt->seg_reg[]
bump PKGREVISION
   2016-08-06 12:10:10 by S.P.Zeidler | Files touched by this commit (5)
Log message:
add patches for XSAs 176, 180 and 181 from upstream
   2016-07-26 16:31:57 by Manuel Bouyer | Files touched by this commit (4) | Package updated
Log message:
Apply security patch from XSA-182 and XSA-183. Bump PKGREVISION
   2016-07-09 15:04:18 by Thomas Klausner | Files touched by this commit (599)
Log message:
Remove python33: adapt all packages that refer to it.
   2016-06-16 11:58:20 by Patrick Welche | Files touched by this commit (1)
Log message:
Change compiler selection logic from "gcc 5" to "gcc >= 5"
(&& gcc == 0 was there such a thing?) as requested by joerg@
   2016-06-14 17:38:54 by Patrick Welche | Files touched by this commit (1)
Log message:
-Wmaybe-uninitialized doesn't exist for NetBSD 6's gcc 4.5.3 and
breaks the build.  It does exist in NetBSD 7's gcc 4.8.4, but the
build is successful without it. So only apply the flag for gcc 5,
as it is necessary for 5.4.0.

Report from jnemeth@
   2016-05-21 18:07:01 by Patrick Welche | Files touched by this commit (1)
Log message:
-Wno-error=maybe-uninitialized to allow compilation with gcc 5.3 on -current