./textproc/redland, Libraries supporting the Resource Description Framework (RDF)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.0.17nb10, Package name: redland-1.0.17nb10, Maintainer: markd

Redland is a set of free software libraries that provide support for the
Resource Description Framework (RDF).
* Modular, object based libraries and APIs for manipulating the RDF graph,
triples, URIs and Literals.
* Storage for graphs in memory and persistently with Sleepycat/Berkeley DB,
MySQL 3-5, PostgreSQL, AKT Triplestore, SQLite, files or URIs.
* Support for multiple syntaxes for reading and writing RDF as RDF/XML,
N-Triples and Turtle Terse RDF Triple Language, RSS and Atom syntaxes via
the Raptor RDF Parser Toolkit.
* Querying with SPARQL and RDQL using the Rasqal RDF Query Library.
* Data aggregation and recording provenance support with Redland contexts.
* Language Bindings in Perl, PHP, Python and Ruby via the Redland Bindings
package.
* Command line utility programs rdfproc (RDF), rapper (parsing) and roqet
(query).
* Portable, fast and with no known memory leaks.


Required to run:
[devel/libltdl] [textproc/rasqal] [textproc/raptor2]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: a47a7e98f934d17d60a241db90be407a0abe3c5d
RMD160: 86bdf793f36ca01197580fe242c4456b8cbfae39
Filesize: 1583.561 KB

Version history: (Expand)


CVS history: (Expand)


   2018-01-28 17:24:15 by Thomas Klausner | Files touched by this commit (71)
Log message:
recursive bump after mpfr shlib major bump
   2018-01-01 22:18:57 by Adam Ciarcinski | Files touched by this commit (629) | Package updated
Log message:
Revbump after boost update
   2017-11-08 23:38:29 by Leonardo Taccari | Files touched by this commit (1)
Log message:
redland: Fix installation if gtk-doc package is already installed

By default redland is configured with `--disable-gtk-doc'. However,
despite that it will checks several `gtkdoc-*' tools anyway ending
in an failure during the installation phase because only a couple
of them are available.

Add a kludge via CONFIGURE_ENV to avoid picking up gtkdoc-* tools.

Pointed out by <oster>, thanks!
   2017-08-24 22:03:43 by Adam Ciarcinski | Files touched by this commit (621) | Package updated
Log message:
Revbump for boost update
   2017-04-30 03:22:04 by Ryo ONODERA | Files touched by this commit (612) | Package updated
Log message:
Recursive revbump from boost update
   2017-01-01 17:06:40 by Adam Ciarcinski | Files touched by this commit (616) | Package updated
Log message:
Revbump after boost update
   2016-10-07 20:26:14 by Adam Ciarcinski | Files touched by this commit (611) | Package updated
Log message:
Revbump post boost update
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.