./www/p5-Starlet, Perl 5 Plack based standalone HTTP/1.0 server

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.30, Package name: p5-Starlet-0.30, Maintainer: pkgsrc-users

The Perl 5 module Starlet provides a standalone HTTP/1.0 server.
It is suitable for running HTTP application servers behind a reverse
proxy and supports the following features: prefork and graceful
shutdown using Parallel::Prefork, hot deployment using Server::Starter,
fast HTTP processing using HTTP::Parser::XS .


Required to run:
[lang/perl5] [sysutils/p5-Server-Starter] [www/p5-Plack] [devel/p5-Parallel-Prefork]

Required to build:
[net/p5-Test-TCP]

Master sites: (Expand)

SHA1: 31bee234b1f3f15ded8db4fac2ab744296d429d3
RMD160: 1fa18408286e2f770e51fb29406ac81b4cd94608
Filesize: 108.245 KB

Version history: (Expand)


CVS history: (Expand)


   2016-07-09 09:05:57 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.30

Upstream changes:
0.30
	- add child_exit hook #26 (by azrle)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-06-05 07:11:18 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.29

Upstream changes:
0.29
	- fix workers being killed too aggressively when spawn-interval is used #27 (by \ 
limitusus)
   2015-11-15 09:10:21 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.28
Update DEPENDS

Upstream changes:
0.28
	- always shutdown after SIGTERM, but only after notifying the client (via \ 
connection: close or equiv.) #23

0.26
	- fix abrupt connection close when receiving SIGTERM #21 (by shogo82148)

0.25
	- support listing to unix socket wo. using Server::Starter
	- suppress warning when receiving broken requests
	- fix test issue with Plack >= 1.0035
   2015-11-04 03:47:43 by Alistair G. Crooks | Files touched by this commit (758)
Log message:
Add SHA512 digests for distfiles for www category

Problems found locating distfiles:
	Package haskell-cgi: missing distfile haskell-cgi-20001206.tar.gz
	Package nginx: missing distfile array-var-nginx-module-0.04.tar.gz
	Package nginx: missing distfile encrypted-session-nginx-module-0.04.tar.gz
	Package nginx: missing distfile headers-more-nginx-module-0.261.tar.gz
	Package nginx: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package nginx-devel: missing distfile echo-nginx-module-0.58.tar.gz
	Package nginx-devel: missing distfile form-input-nginx-module-0.11.tar.gz
	Package nginx-devel: missing distfile lua-nginx-module-0.9.16.tar.gz
	Package nginx-devel: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx-devel: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package php-owncloud: missing distfile owncloud-8.2.0.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-01-12 14:16:41 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update 0.18 to 0.24
0.24
	- worker processes always receive different sequence of values when
	  calling "rand()"
0.23
	- serialize calls to select -> accept when listening to multiple ports
0.22
	- listen to multiple ports passed from Server::Starter (ttakezawa)
0.21
	- support listening to unix socket (passed by Server::Starter) (kazeburo)
0.20
	- support HTTP/1.1 (kazeburo)
0.19
	- update the dependencies now that Plack no more depends on LWP
          (miyagawa; https://github.com/plack/Plack/pull/408)
	- add support for psgix.harakiri (audreyt)
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.