./www/p5-Twiggy, AnyEvent HTTP server for PSGI

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.1025nb3, Package name: p5-Twiggy-0.1025nb3, Maintainer: pkgsrc-users

the Perl 5 module Twiggy is a lightweight and fast HTTP server with
unique features such as: PSGI, AnyEvent, fast header parser,
and superdaemon aware.


Required to run:
[lang/perl5] [devel/p5-AnyEvent] [devel/p5-EV] [devel/p5-Try-Tiny]

Required to build:
[net/p5-Test-TCP] [devel/p5-Test-Requires] [sysutils/p5-Server-Starter] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 36ff5a722317ae4531534a66718004ca14690d4b
RMD160: daee2ec42d12ce22ce9dfda41dea6effdf609077
Filesize: 60.629 KB

Version history: (Expand)


CVS history: (Expand)


   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2015-11-04 03:47:43 by Alistair G. Crooks | Files touched by this commit (758)
Log message:
Add SHA512 digests for distfiles for www category

Problems found locating distfiles:
	Package haskell-cgi: missing distfile haskell-cgi-20001206.tar.gz
	Package nginx: missing distfile array-var-nginx-module-0.04.tar.gz
	Package nginx: missing distfile encrypted-session-nginx-module-0.04.tar.gz
	Package nginx: missing distfile headers-more-nginx-module-0.261.tar.gz
	Package nginx: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package nginx-devel: missing distfile echo-nginx-module-0.58.tar.gz
	Package nginx-devel: missing distfile form-input-nginx-module-0.11.tar.gz
	Package nginx-devel: missing distfile lua-nginx-module-0.9.16.tar.gz
	Package nginx-devel: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx-devel: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package php-owncloud: missing distfile owncloud-8.2.0.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2015-01-12 14:33:34 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Update 0.1024 to 0.1025
0.1025  2015-01-04 07:00:16 JST
        - Fix a bug where Twiggy's run loop exits after a streaming
          request is cut off (hoelzro) #41
   2014-05-30 01:38:20 by Thomas Klausner | Files touched by this commit (3049)
Log message:
Bump for perl-5.20.0.
Do it for all packages that
* mention perl, or
* have a directory name starting with p5-*, or
* depend on a package starting with p5-
like last time, for 5.18, where this didn't lead to complaints.
Let me know if you have any this time.
   2014-05-03 12:04:24 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.1024

Upstream changes:
0.1024  2013-10-12 11:35:35 PDT
        - Fix a bug where exit_guard is not correctly decremented when writing \ 
header failed (maedama) #37

0.1023  2013-06-15 01:51:22 PDT
        - Move the bin directory (moznion) #35

0.1022  2013-06-12 12:36:16 PDT
        - convert to use Milla
        - Fix dependency for LWP

0.1021 Fri Oct 19 15:09:17 PDT 2012
        - Repackage with the latest Module::Install

0.1020 Mon Feb 20 16:31:44 PST 2012
        - Improve SEREVR_PORT when binding multiple ports
        - Documentation fixes (Pedro Melo)
        - Suppres 400 if client disconnected (athomason)
        - Don't restrict parsing the request body to PUT and POST requests \ 
(Moritz Onken)
        - Fixed broken POST data processing (und3f, hidekiy)
   2013-05-31 14:42:58 by Thomas Klausner | Files touched by this commit (2880)
Log message:
Bump all packages for perl-5.18, that
a) refer 'perl' in their Makefile, or
b) have a directory name of p5-*, or
c) have any dependency on any p5-* package

Like last time, where this caused no complaints.