./x11/libxfce4ui, Xfce widget library

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.13.4, Package name: libxfce4ui-4.13.4, Maintainer: youri

This is libxfce4ui, the replacement of the old libxfcegui4 library. It
is used to share commonly used Xfce widgets amoung the Xfce applications.


Required to run:
[sysutils/desktop-file-utils] [graphics/hicolor-icon-theme] [x11/gtk2] [x11/libxfce4util] [x11/startup-notification] [x11/gtk3] [devel/xfce4-conf]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

SHA1: 480de7fa8e9cb14902ebb6af13054bfdd5bae947
RMD160: 1b391568fd5af19d7fb16d49132718e94c76681d
Filesize: 668.032 KB

Version history: (Expand)


CVS history: (Expand)


   2018-05-27 16:58:19 by Youri Mouton | Files touched by this commit (2)
Log message:
Add vendor info and tiny buildlink fix.
   2018-05-16 00:39:40 by Youri Mouton | Files touched by this commit (3) | Package updated
Log message:
Update:

4.13.4
======
- Fix missing gresource file in release tarball (Bug #13705)
- Add Vala support (Vidar Haarr)
- Fix gladeui2 path detection (Bug #13944)
- Fix make distcheck (Bug #14039)
- Fix incorrect use of AC_ARG_ENABLE(tests..) (Bug #13703)
- Use BOOLEAN instead of deprecated BOOL
- Allows to properly show some characters, such as ampersand (Bug #12715)
- Add api indices in gtk-doc
- Translation Updates: Amharic, Arabic, Asturian, Bulgarian, Catalan, Czech, \ 
Danish, German, Greek, English (Australia), English (United Kingdom), Spanish, \ 
Basque, Finnish, French, Galician, Hebrew, Croatian, Hungarian, Indonesian, \ 
Icelandic, Italian, Japanese, Kazakh, Korean, Lithuanian, Malay, Norwegian \ 
Bokmål, Dutch, Norwegian Nynorsk, Occitan (post 1500), Polish, Portuguese, \ 
Portuguese (Brazil), Romanian, Russian, Slovak, Slovenian, Serbian, Swedish, \ 
Telugu, Thai, Turkish, Uighur, Ukrainian, Chinese (China), Chinese (Hong Kong), \ 
Chinese (Taiwan)

4.13.3
======
- Fix make distcheck with gladeui2 install path
- Add an --enable-tests option
- Remove the filterout from introspection sources
- Move gresource building out of maintainer mode
- Fix condition in confirm dialog
- Add POTFILES.skip to appease gmake distcheck gods on OpenBSD
- ship libxfce4ui.gresource.xml in the tarball too
- Add libxfce4ui-marshal.list to EXTRA_DIST to fix
  --enable-maintainer-mode on released tarballs
- Fix build error with --disable-gtk2
- Translation updates: bg, cs, fr, it, ca, hr, it, da, ru.

4.13.2
======
- Fix build error with --disable-gtk3 Bug #12648
- Improve layout of labels in xfce dialogs
- Set a reasonable default window width to make sure labels wrap
- Improve vertical alignment of primary and secondary label
- Bump the default dialog width to 500px
- Update libxfce4ui documentation
- Fix make docs compilation warning
- Fix xfce_dialog_show_help(_with_version) doc
- Remove Makefile.am space to fix autogen.sh warning
- Better documentation processing
- Change xfce_dialog_show_help(_with_version)
- Default debug to yes instead of full
- Remove exo dependancy Bug #13326
- fix: add libxfce4ui_get_resource to abi check symbols Bug #13326
- Let autotools find and invoke glib-compile-resources Bug #13326
- Add support for GOBJECT-INTROSPECTION Bug #13461
- Add GtkDoc checks
- Add missing introspection.m4 file
- fix: make distcheck
- fix: remove deprecation warnings
- feat: Switch to Gtk3 default, Gtk2 Optional
- Rename introspection GIR to 4ui-2.0 to match util
- Translation updates: am ast ca da el eu fi gl id it ko lt ms nn
                       oc pl pt ro ru sl sr th zh_CN zh_TW
   2018-04-16 16:35:28 by Thomas Klausner | Files touched by this commit (1284)
Log message:
Recursive bump for new fribidi dependency in pango.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2017-11-23 18:20:22 by Thomas Klausner | Files touched by this commit (556)
Log message:
recursive bump for libxkbcommon removal from at-spi2-core
   2017-06-19 14:31:41 by Youri Mouton | Files touched by this commit (1)
Log message:
Add gtk2 dependency.
   2017-06-18 23:13:47 by Youri Mouton | Files touched by this commit (4) | Package updated
Log message:
Update libxfce4ui to 4.13.1:

4.13.1
======
- Better Gtk3.20 compatibility (fix XfceHeading style, drop deprecated call)
- Translation updates: Bulgarian, Catalan, Chinese (China), Chinese (Taiwan),
  Croatian, Czech, Danish, Dutch (Flemish), English (Australia), French, German,
  Hebrew, Japanese, Korean, Lithuanian, Norwegian Bokm?l, Polish, Portuguese
  (Brazilian), Russian, Slovak, Spanish, Swedish, Thai, Turkish, Ukrainian
   2017-02-12 07:26:18 by Ryo ONODERA | Files touched by this commit (1451)
Log message:
Recursive revbump from fonts/harfbuzz