./x11/py-qt5, Python binding for Qt5

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 5.10, Package name: py27-qt5-5.10, Maintainer: pkgsrc-users

PyQt is a set of Python bindings for the Qt toolkit. PyQt brings
together the Qt C++ cross-platform toolkit and the cross-platform
interpreted language Python. PyQt contains 300 classes and over
5,750 functions and methods.

PyQt also includes the pyuic and pylupdate utilities which correspond
to the Qt uic and lupdate utilities. pyuic converts the GUI designs
created with Qt Designer to executable Python code. pylupdate
scans Python code, extracts all strings that are candidates for
internationalisation, and creates an XML file for use by Qt Linguist.

This package is for QT5.


Required to run:
[sysutils/py-dbus] [x11/py-sip] [lang/python27] [x11/qt5-qtsvg] [x11/qt5-qttools] [x11/qt5-qtdeclarative] [x11/qt5-qtlocation] [x11/qt5-qtsensors] [x11/qt5-qtwebkit] [x11/qt5-qtxmlpatterns] [x11/qt5-qtbase] [x11/qt5-qtmultimedia] [x11/qt5-qtwebsockets]

Required to build:
[pkgtools/x11-links] [x11/compositeproto] [x11/glproto] [x11/renderproto] [x11/xproto] [x11/xf86vidmodeproto] [x11/recordproto] [x11/xf86driproto] [x11/damageproto] [x11/inputproto] [x11/xextproto] [x11/randrproto] [x11/dri2proto] [x11/xcb-proto] [x11/fixesproto4] [sysutils/dbus-python-common] [pkgtools/cwrappers]

Master sites:

SHA1: 14d68357685b6c9c0db9e747772ca3f80e0c8def
RMD160: f9db4a93c335126006827df7d39b1e35f17f9156
Filesize: 3037.045 KB

Version history: (Expand)


CVS history: (Expand)


   2018-02-01 22:09:29 by Adam Ciarcinski | Files touched by this commit (4) | Package updated
Log message:
py-qt5: updated to 5.10

v5.10:
- Added support for Qt v5.10.0.
- Added the QtNetworkAuth module.
   2018-01-28 21:11:10 by Thomas Klausner | Files touched by this commit (462) | Package updated
Log message:
Bump PKGREVISION for gdbm shlib major bump
   2018-01-23 20:36:35 by Mark Davies | Files touched by this commit (1)
Log message:
py-qt5: remove commented out SUBST_CLASS.install
   2018-01-23 20:35:08 by Mark Davies | Files touched by this commit (1)
Log message:
py-qt5: restore PLIST as well
   2018-01-23 17:42:02 by Darrin B. Jewell | Files touched by this commit (2)
Log message:
it was pointed out that python27 is a build only dependency for qt5-qtwebkit
revert previous
   2018-01-22 05:36:08 by Darrin B. Jewell | Files touched by this commit (3)
Log message:
if PYPKGPREFIX is not py27, disable QtWebKit and remove it as a dependency
   2018-01-22 05:17:11 by Darrin B. Jewell | Files touched by this commit (2)
Log message:
Do not expect an app bundle on Darwin.
   2018-01-22 00:32:45 by Mark Davies | Files touched by this commit (2)
Log message:
py-qt5: fix PLIST for python2 and note dependency on py-dbus