./x11/xfce4-exo, Xfce extension library

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.12.5, Package name: xfce4-exo-0.12.5, Maintainer: youri

The Xfce extension library is targeted at application development.


Required to run:
[sysutils/desktop-file-utils] [www/p5-URI] [graphics/hicolor-icon-theme] [lang/perl5] [x11/gtk2] [x11/gtk3] [x11/libxfce4ui]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

SHA1: 0c63ac01443687c584c04ba359ea3b58b5bdd042
RMD160: 15656ac2d335cfb8fe1905a2ce906acb7fb21013
Filesize: 1207.282 KB

Version history: (Expand)


CVS history: (Expand)


   2019-05-04 04:01:35 by David H. Gutteridge | Files touched by this commit (3) | Package updated
Log message:
xfce4-exo: update to 0.12.5

0.12.5
======
- Bug Fixes:
  - Fix typehead in ExoIconView (Xfce #15100)
- Build Updates:
  - Building libexo-1 can now be disabled (Xfce #15138, #15199)
    - Building documentation still requires libexo-1 since some older
      symbols exists only in the GTK+ 2 library
  - Several components were moved around to align with the correct
    library versions:
    - Helpers are now installed in exo-2 paths, and exo-helper-1 has
      been renamed to exo-helper-2 to follow the library version
    - Pixmaps were moved to an unversioned path (pixmaps/exo) since
      they are used by both versions of the library
    - exo-compose-mail has dropped the library version since it
      does not depend on either version of the library
  - The expansion-to-defined flag was re-enabled
- Translation Updates: Albanian, Bulgarian, Danish, Dutch,
  English (United Kingdom), Finnish, Indonesian, Korean, Spanish
   2019-02-17 17:07:51 by Youri Mouton | Files touched by this commit (2) | Package updated
Log message:
Update exo to 0.12.4:

- Small fixes and translations updates
   2019-01-18 15:39:34 by Youri Mouton | Files touched by this commit (2) | Package updated
Log message:
xfce4-exo: update to 0.12.3:

0.12.3
======
- General:
  - Preferred Applications: Improved layout spacing and alignment
  - Resolved g_type_class_add_private deprecations (GObject 2.58)
- Bug Fixes:
  - Hide exo launchers from GNOME Software (Xfce #14588)
  - Fix crash with "preedit-changed" signal (Xfce #14756)
- Translation updates: Albanian, Amharic, Arabic, Asturian, Basque,
  Belarusian, Bengali, Bulgarian, Catalan, Chinese (China),
  Chinese (Hong Kong), Chinese (Taiwan), Croatian, Czech, Danish,
  Dutch, English (Australia), Estonian, Finnish, French, Galician,
  German, Greek, Hebrew, Hungarian, Icelandic, Indonesian, Italian,
  Japanese, Kazakh, Korean, Latvian, Lithuanian, Malay, Norwegian Bokmål,
  Norwegian Nynorsk, Occitan (post 1500), Panjabi (Punjabi), Polish,
  Portuguese, Portuguese (Brazil), Romanian, Russian, Serbian, Slovak,
  Slovenian, Spanish, Swedish, Telugu, Thai, Turkish, Uighur, Ukrainian,
Urdu, Urdu (Pakistan), Vietnamese
   2018-11-14 23:22:54 by Klaus Klein | Files touched by this commit (1332) | Package updated
Log message:
Revbump after cairo 1.16.0 update.
   2018-11-12 04:53:16 by Ryo ONODERA | Files touched by this commit (1532)
Log message:
Recursive revbump from hardbuzz-2.1.1
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-06-23 22:37:26 by Youri Mouton | Files touched by this commit (4) | Package updated
Log message:
Update xfce4-exo to 0.12.2:

- a bunch of bug fixes
- exo icon chooser dialog fixed

https://bluesabre.org/2018/06/20/exo-0- … -released/
   2018-05-16 00:36:44 by Youri Mouton | Files touched by this commit (3) | Package updated
Log message:
Update:

0.12.0 (Stable Release)
======
- Bug Fixes:
  - Add google-chrome-stable binary for the google-chrome helper (Xfce #13876)
- Build Changes:
  - Requirements updated: GTK 2.24, GTK 3.22, GLib 2.42, libxfce4ui 4.12,
    libxfce4util 4.12
- Translation Updates: Albanian, Amharic, Arabic, Asturian, Basque,
  Belarusian, Bengali, Bulgarian, Catalan, Chinese (China),
  Chinese (Hong Kong), Chinese (Taiwan), Croatian, Czech, Danish, Dutch,
  English (Australia), English (United Kingdom), Estonian, Finnish, French,
  Galician, German, Greek, Hebrew, Hungarian, Icelandic, Indonesian, Italian,
  Japanese, Kannada, Kazakh, Korean, Latvian, Lithuanian, Malay,
  Norwegian Bokmal, Norwegian Nynorsk, Occitan (post 1500), Panjabi (Punjabi),
  Polish, Portuguese, Portuguese (Brazil), Romanian, Russian, Serbian,
  Sinhala, Slovak, Slovenian, Spanish, Swedish, Telugu, Thai, Turkish, Uighur,
  Ukrainian, Urdu, Urdu (Pakistan), Vietnamese

0.11.5 (Development Release)
======
- New Features:
  - ExoString: Added new exo_str_is_flag
  - Helpers: Added Terminator (TerminalEmulator) (Xfce #13714)
- Bug Fixes:
  - exo-helper: Use full custom command path (Xfce #4093)
  - exo-launch: Pass flags to preferred application (Xfce #9427)
  - Replaced internet-mail icon with FD.o compliant emblem-mail (Xfce #13711)
  - Dropped conflicting Vivaldi helper (Xfce #13712, Gentoo #624546)
- Translation Updates: Bulgarian, Catalan, Chinese (China), Chinese (Taiwan),
  Croatian, Danish, Dutch, French, German, Hebrew, Indonesian, Kazakh, Korean,
  Lithuanian, Norwegian Bokmal, Polish, Portuguese (Brazil), Russian, Spanish,
  Swedish, Turkish

0.11.4 (Development Release)
======
From a development standpoint, this release can be considered the first release
candidate for the 0.12.x series. Full GTK+ 2 and 3 support is now available
and should meet the needs for any Xfce application development.
- New Features:
  - GTK Extensions: Added new exo_gtk_dialog_get_action_area and
    exo_gtk_dialog_add_secondary_button
  - GTK3: Added support for insensitive state in exo_cell_renderer_icon
  - Helpers: Added Brave, Google Chrome, and Vivaldi (WebBrowser)
  - Helpers: Added Geary (MailReader)
  - Helpers: Dropped Opera Mail (no longer available for Linux)
- Bug Fixes:
  - Removed --disable-debug flag from distcheck (Xfce #11556)
- Icons:
  - Replaced non-standard gnome-* icons
  - Replaced non-existent "missing-image" icon
- Deprecations:
  - Dropped gdk_window_process_updates for GTK+ 3.22
  - Replaced gdk_pixbuf_new_from_inline usage
  - Replaced gdk_screen_* usage
  - Replaced gtk_style_context_get_background_color usage
  - Removed warnings for gtk_dialog_get_action_area and GioScheduler
- Translation Updates: Arabic, Catalan, Chinese (China), Danish, Dutch, French,
  German, Hebrew, Indonesian, Korean, Lithuanian, Portuguese (Brazil), Russian,
  Spanish, Swedish