Subject: CVS commit: pkgsrc/security/py-paramiko
From: Adam Ciarcinski
Date: 2017-11-15 10:24:14
Message id: 20171115092414.B7ABCFB3E@cvs.NetBSD.org

Log Message:
py-paramiko: updated to 2.4.0

2.4.0:

[Feature]: Add a new passphrase kwarg to SSHClient.connect so users may \ 
disambiguate key-decryption passphrases from password-auth passwords. (This is a \ 
backwards compatible change; password will still pull double duty as a \ 
passphrase when passphrase is not given.)
[Support]: Drop Python 2.6 and Python 3.3 support; now only 2.7 and 3.4+ are \ 
supported. If you’re unable to upgrade from 2.6 or 3.3, please stick to the \ 
Paramiko 2.3.x (or below) release lines.
[Support]: Include LICENSE file in wheel archives.
[Support]: Updated the test suite & related docs/metadata/config to be \ 
compatible with pytest instead of using the old, custom, crufty unittest-based \ 
test.py.

This includes marking known-slow tests (mostly the SFTP ones) so they can be \ 
filtered out by inv test‘s default behavior; as well as other minor tweaks to \ 
test collection and/or display (for example, GSSAPI tests are collected, but \ 
skipped, instead of not even being collected by default as in test.py.)

[Support]: Update tearDown of client test suite to avoid hangs due to eternally \ 
blocking accept() calls on the internal server thread (which can occur when test \ 
code raises an exception before actually connecting to the server.)

Files:
RevisionActionfile
1.18modifypkgsrc/security/py-paramiko/distinfo
1.31modifypkgsrc/security/py-paramiko/Makefile