Subject: CVS commit: pkgsrc/security
From: Adam Ciarcinski
Date: 2020-04-03 08:25:50
Message id: 20200403062550.B5144FB27@cvs.NetBSD.org

Log Message:
py-cryptography{_vectors}: updated to 2.9

2.9:
* **BACKWARDS INCOMPATIBLE:** Support for Python 3.4 has been removed due to
  low usage and maintenance burden.
* **BACKWARDS INCOMPATIBLE:** Support for OpenSSL 1.0.1 has been removed.
  Users on older version of OpenSSL will need to upgrade.
* **BACKWARDS INCOMPATIBLE:** Support for LibreSSL 2.6.x has been removed.
* Removed support for calling
  \ 
:meth:`~cryptography.hazmat.primitives.asymmetric.x25519.X25519PublicKey.public_ \ 
bytes`
  with no arguments, as per our deprecation policy. You must now pass
  ``encoding`` and ``format``.
* **BACKWARDS INCOMPATIBLE:** Reversed the order in which
  :meth:`~cryptography.x509.Name.rfc4514_string` returns the RDNs
  as required by :rfc:`4514`.
* Updated Windows, macOS, and ``manylinux`` wheels to be compiled with
  OpenSSL 1.1.1f.
* Added support for parsing
  :attr:`~cryptography.x509.ocsp.OCSPResponse.single_extensions` in an OCSP
  response.
* :class:`~cryptography.x509.NameAttribute` values can now be empty strings.

Files:
RevisionActionfile
1.23modifypkgsrc/security/py-cryptography_vectors/distinfo
1.14modifypkgsrc/security/py-cryptography_vectors/PLIST
1.23modifypkgsrc/security/py-cryptography_vectors/Makefile
1.61modifypkgsrc/security/py-cryptography/distinfo
1.76modifypkgsrc/security/py-cryptography/Makefile