./converters/ruby-unf_ext, Unicode Normalization Form support library for CRuby

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.0.7.5, Package name: ruby23-unf_ext-0.0.7.5, Maintainer: pkgsrc-users

Unicode Normalization Form support library for CRuby.


Required to run:
[lang/ruby23-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 4641725bb83a536b5248e0aa6f8a497ef23f9ce5
RMD160: e945c8d6173f724a6fa137bd9597fdacc2017879
Filesize: 389.5 KB

Version history: (Expand)


CVS history: (Expand)


   2018-02-18 06:44:50 by Izumi Tsutsui | Files touched by this commit (2) | Package updated
Log message:
ruby-unf_ext: update to 0.0.7.5.

Upstream changelog (from CHANGELOG.md):

## 0.0.7.5 (2018-02-06)

- Version bump just for adding Windows binaries for Ruby 2.5.
   2017-07-31 00:32:28 by Thomas Klausner | Files touched by this commit (229)
Log message:
Switch github HOMEPAGEs to https.
   2017-04-22 18:11:03 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-unf_ext to 0.0.7.4.

## 0.0.7.4 (2017-04-19)

- Fix build on ARM and GCC 6 again.

## 0.0.7.3 (2017-04-11)

- Update the base Unicode version to 9.

- Fix compile issues on ARM and GCC 6.
   2016-02-16 15:20:01 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-unf_ext to 0.0.7.2.

## 0.0.7.2 (2016-02-01)

- Version bump just for adding Windows binaries for Ruby 2.3.
   2015-11-03 02:43:56 by Alistair G. Crooks | Files touched by this commit (120)
Log message:
Add SHA512 digests for distfiles for converters category

Problems found with existing distfile:
	distfiles/libiconv-1.13-cp932.patch.gz
No changes made to the libiconv distinfo file.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-06-04 15:57:38 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-unf_ext to 0.0.7.1.

## 0.0.7.1 (2015-04-18)

- Windows fat binary gems no longer require libstd++ to
  run, which are statically linked.

- Add a fat binary gem for x64-mingw32 (64bit Windows).

- Windows fat binary gems now include binaries for Ruby up to 2.2.
   2015-03-08 16:17:22 by Takahiro Kambe | Files touched by this commit (58) | Package updated
Log message:
Add ${GEM_EXTSDIR}/gem.build_complete for new rubygems and updated ruby.
   2014-03-13 19:11:16 by Takahiro Kambe | Files touched by this commit (1)
Log message:
Add GEM_EXTSDIR support.

No functional change for current versions of Rubys.