./devel/ruby-getopt, Another option parsers for Ruby

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.4.3, Package name: ruby200-getopt-1.4.3, Maintainer: pkgsrc-users

The getopt library provides two different command line option parsers.
They are meant as easier and more convenient replacements for the
command line parsers that ship as part of the Ruby standard library.
Please see the README for additional comments.


Required to run:
[lang/ruby200-base]

Master sites:

SHA1: fe5cb666293c24529a425125d203cd723ffa37f4
RMD160: d8260088c103ad363fadc9005bf80e2281463223
Filesize: 20 KB

Version history: (Expand)


CVS history: (Expand)


   2016-01-11 17:01:37 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-getopt to 1.4.3.

== 1.4.3 - 7-Jan-2016
* This gem is now signed.
* The gem related tasks in the Rakefile now assume Rubygems 2.x.
* Added getopt.rb, getopt-std.rb and getopt-long.rb files for convenience.
   2015-11-03 04:29:40 by Alistair G. Crooks | Files touched by this commit (1995)
Log message:
Add SHA512 digests for distfiles for devel category

Issues found with existing distfiles:
	distfiles/eclipse-sourceBuild-srcIncluded-3.0.1.zip
	distfiles/fortran-utils-1.1.tar.gz
	distfiles/ivykis-0.39.tar.gz
	distfiles/enum-1.11.tar.gz
	distfiles/pvs-3.2-libraries.tgz
	distfiles/pvs-3.2-linux.tgz
	distfiles/pvs-3.2-solaris.tgz
	distfiles/pvs-3.2-system.tgz
No changes made to these distinfo files.

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-25 10:51:12 by Takahiro Kambe | Files touched by this commit (1) | Package updated
Log message:
Update HOMEPAGE.
Avoid using rubyforge.org since it stopped most of services.
   2015-02-01 15:17:40 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-getopt to 1.4.2.

== 1.4.2 - 12-Oct-2014
* Updated Rakefile, README and gemspec.
* Minor updates to the test file and examples.
   2011-08-12 18:31:07 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update devel/ruby-getopt package to 1.4.1.

== 1.4.1 - 17-Jul-2011
* Now works with Ruby 1.9.x. Thanks go to Shura for the patch.
* Refactored the gemspec. Gem building code is now handled by Rake tasks.
* Refactored the Rakefile. Added a default task, removed the old install
  task, and namespaced the gem related tasks.
   2010-09-23 09:18:43 by Takahiro Kambe | Files touched by this commit (4) | Imported package
Log message:
Importing devel/ruby-getopt 1.4.0.