./editors/emacs-packages, Meta-package for the GNU Emacs lisp packages

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.10, Package name: emacs-packages-0.10, Maintainer: uebayasi

This is our equivalent to XEmacs's ``sumo'' package - Emacs lisp
package collection for FSF Emacs 20 / 21.


Required to run:
[chat/riece] [chat/zenirc] [chat/irchat-pj] [chat/zenicb] [textproc/flyspell] [textproc/emacs-dict-client] [textproc/psgml-mode] [textproc/ispell-emacs] [cad/verilog-mode] [print/auctex] [misc/bbdb] [graphics/artist] [editors/tamago] [editors/matlab-mode] [editors/speedbar] [math/ess] [inputmethod/skk] [inputmethod/tc] [mail/mailcrypt] [mail/etach] [mail/vm] [mail/mew] [devel/elib] [devel/sml-mode] [devel/doxymacs] [devel/emacs-ilisp] [devel/flim] [devel/ruby-rd-mode] [devel/apel] [devel/python-mode] [devel/haskell-mode] [devel/ruby-mode] [devel/semi] [www/emacs-w3m-snapshot] [mail/wl-snapshot] [editors/emacs24]

Version history: (Expand)


CVS history: (Expand)


   2015-04-05 22:09:05 by John Nemeth | Files touched by this commit (1)
Log message:
elscreen is an old unmaintained package that doesn't work with emacs >= 24.

Approved By: uebayasi@
   2015-03-26 17:02:08 by Joerg Sonnenberger | Files touched by this commit (1)
Log message:
navi2ch is gone. Bump revision.
   2013-02-17 20:18:11 by David A. Holland | Files touched by this commit (90)
Log message:
Revbump all elisp packages after emacs changes.
   2011-04-14 20:20:56 by Hans Rosenfeld | Files touched by this commit (1)
Log message:
Fix some dependencies for emacs 23.

For mail/wl and www/emacs-w3m, only the snapshot versions work with
emacs 23, while lang/eieio and devel/semantic don't work at all.
   2009-04-09 00:55:07 by Joerg Sonnenberger | Files touched by this commit (1)
Log message:
Use META_PACKAGE.
   2008-10-11 11:31:58 by Masao Uebayashi | Files touched by this commit (100)
Log message:
Move mk/emacs.mk to editors/emacs/modules.mk.

Don't call pkg_info to get the installed Emacs version; always use the
version matching EMACS_TYPE set by users.  Be DEPENDS to it.  This should
address pkg/37146 by Aleksey Cheusov.

While here convert some emacs lisp packages to user-destdir.
   2007-10-30 13:46:01 by David Sainty | Files touched by this commit (1)
Log message:
Somewhat overdue, add devel/doxymacs.  Bump to 0.9.
   2007-10-29 14:27:55 by Masao Uebayashi | Files touched by this commit (1)
Log message:
Welcome to version 0.8:

* Add misc/elscreen.

* Fix build for Emacs 22.