./ham/gr-osmosdr, SDR Hardware support for OsmoSDR and so many more

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.1.4nb15, Package name: gr-osmosdr-0.1.4nb15, Maintainer: pkgsrc-users

While primarily being developed for the OsmoSDR hardware, this block
as well supports:

* FUNcube Dongle through libgnuradio-fcd
* FUNcube Dongle Pro+ through gr-fcdproplus
* sysmocom OsmoSDR Devices through libosmosdr
* RTL2832U based DVB-T dongles through librtlsdr
* RTL-TCP spectrum server (see librtlsdr project)
* MSi2500 based DVB-T dongles through libmirisdr
* gnuradio .cfile input through libgnuradio-blocks
* RFSPACE SDR-IQ, SDR-IP, NetSDR (incl. X2 option)
* AirSpy Wideband Receiver through libairspy
* Great Scott Gadgets HackRF through libhackrf
* Nuand LLC bladeRF through libbladeRF library
* Ettus USRP Devices through Ettus UHD library
* Fairwaves UmTRX through Fairwaves' fork of UHD

By using the OsmoSDR block you can take advantage of a common software api in
your application(s) independent of the underlying radio hardware.


Required to run:
[ham/gnuradio-core] [devel/boost-libs] [devel/orc] [lang/python27] [devel/libusb1] [ham/uhd] [ham/gnuradio-uhd] [ham/gnuradio-fcd] [ham/hackrf] [ham/libmirisdr] [ham/rtl-sdr] [ham/osmo-sdr]

Required to build:
[devel/boost-headers] [pkgtools/cwrappers]

Master sites:

SHA1: 672041a6ffa767d39ffad2432e2a13c11e3ec984
RMD160: 30f97d10655e5a88fdf2bf43a323ea9d9aba0479
Filesize: 217.735 KB

Version history: (Expand)


CVS history: (Expand)


   2019-09-02 15:20:22 by Adam Ciarcinski | Files touched by this commit (415)
Log message:
Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for \ 
future Python 3.8
   2019-08-22 14:23:56 by Ryo ONODERA | Files touched by this commit (678)
Log message:
Recursive revbump from boost-1.71.0
   2019-07-01 06:08:55 by Ryo ONODERA | Files touched by this commit (669)
Log message:
Recursive revbump from boost-1.70.0
   2019-04-30 18:13:42 by Greg Troxel | Files touched by this commit (1)
Log message:
ham/gr-osmosdr: Mark python 36 and 37 as not ok

Both 36 and 37 result in build errors.  The package builds ok with 27.
   2019-04-25 09:33:32 by Maya Rashish | Files touched by this commit (620)
Log message:
PKGREVISION bump for anything using python without a PYPKGPREFIX.

This is a semi-manual PKGREVISION bump.
   2018-12-13 20:52:27 by Adam Ciarcinski | Files touched by this commit (668)
Log message:
revbump for boost 1.69.0
   2018-09-25 03:14:39 by Greg Troxel | Files touched by this commit (1)
Log message:
gr-osmosdr: Drop gr-fcdproplus as a dependency

gr-fcdproplus does not build.  Drop it, so that gr-osmosdr builds
with the rest of the sources.  Leave a \todo for when fcdproplus is
fixed.
   2018-09-24 14:04:40 by Greg Troxel | Files touched by this commit (1)
Log message:
gr-osmosdr: Add comments to Makefile