./security/p5-Crypt-PWSafe3, Perl module interface to Passwordsafe v3 files

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.22nb1, Package name: p5-Crypt-PWSafe3-1.22nb1, Maintainer: pkgsrc-users

Crypt::PWSafe3 provides read and write access to password database
files created by Password Safe V3 (and up).


Required to run:
[lang/perl5] [security/p5-Digest-HMAC] [security/p5-Crypt-CBC] [security/p5-Crypt-Random] [security/p5-Crypt-Twofish] [devel/p5-Data-UUID] [devel/p5-File-Temp] [security/p5-Crypt-ECB]

Master sites: (Expand)

SHA1: 9a06716b36ebef5b26ea2384f4372582a5103fee
RMD160: facaf1dad1690ea4021c4f0225a0bc99afeced77
Filesize: 25.807 KB

Version history: (Expand)


CVS history: (Expand)


   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-04-08 16:46:13 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
Update p5-Crypt-PWSafe3 to 1.22.

1.22:	Records created by Crypt::PWSafe3 (eg. the ones fetched
	with getrecords) are now associated with the parent
	object, so that you can modify them directly and call
	$vault->save afterwards without using $vault->modifyrecord.

        Erase passwd from memory using zeros instead of
        random bytes. fixes github#9.

	Fixed rt.cpan.org#112975: Crypt::ECB (which we use) have been
	reworked and among other issues it fixed handline of padding.
	PWSafe3.pm did not specify a padding scheme (because it doesn't
	use it) and therefore Crypt::ECB enforced a default scheme
	which lead to an invalid key size. Now we specify explicitly
	padding:none, as suggested by Christoph Appel.
   2015-12-11 14:15:19 by Thomas Klausner | Files touched by this commit (3)
Log message:
Import p5-Crypt-PWSafe3-1.21 as security/p5-Crypt-PWSafe3.

All tests pass.

Crypt::PWSafe3 provides read and write access to password database
files created by Password Safe V3 (and up).