./security/p5-Crypt-CBC, Perl5 cipher block chaining mode for various crypto algorithms

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.04, Package name: p5-Crypt-CBC-3.04, Maintainer: pkgsrc-users

This is Crypt::CBC, a Perl-only implementation of the cryptographic
cipher block chaining mode (CBC). In combination with a block cipher
such as Crypt::DES or Crypt::IDEA, you can encrypt and decrypt
messages of arbitrarily long length. The encrypted messages are
compatible with the encryption format used by SSLeay.

In addition to this module you will need to install the MD5 module,
and one or more of the Crypt::DES, Crypt::IDEA, or Crypt::Blowfish
modules.


Required to run:
[lang/perl5]

Required to build:
[security/p5-Crypt-Rijndael] [pkgtools/cwrappers]

Master sites: (Expand)

RMD160: 79a7ada687c38b38a93bddb1e80a920bdad1f8e6
Filesize: 39.294 KB

Version history: (Expand)


CVS history: (Expand)


   2021-10-07 16:54:50 by Nia Alarie | Files touched by this commit (606)
Log message:
security: Remove SHA1 hashes for distfiles
   2021-07-02 13:27:21 by Nia Alarie | Files touched by this commit (2) | Package updated
Log message:
p5-Crypt-CBC: Update to 3.04.

Fix packaging on 32-bit platforms by disabling int128 dependency.

3.04	 Mon 17 May 2021 10:58:37 AM EDT
        - Fixed bug involving manually-specified IV not being used in some \ 
circumstances.
   2021-05-24 21:56:06 by Thomas Klausner | Files touched by this commit (3575)
Log message:
*: recursive bump for perl 5.34
   2021-04-27 12:51:00 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-Crypt-CBC: update to 3.03.

3.03    Sun 18 Apr 2021 10:54:19 PM EDT
	- Fixed bug which caused an extraneous block of garbage data to be appended to \ 
encrypted
	  string when "nopadding" specified and plaintext is even multiple of \ 
blocksize.

3.02
	- CTR mode now requires the Math::Int128 module, which gives a ~5x performance
	  boost over Math::BigInt.

3.01
	- Warn when the deprecated opensslv1 PBKDF (key derivation function) is used
	  for encryption. Turn off with -nodeprecate=>1 or by choosing a different
	  PBKDF, such as -pbkdf=>'pbkdf2'.
	- Fix a regression when passing the legacy -salt=>1 argument.

3.00    Sun Feb  7 10:28:08 EST 2021
        - Released version 3.00 in recognition of multiple new features
	  and cleanups.

2.37    Sun Feb  7 10:20:17 EST 2021
        - Added better argument checking.
	- Fixed long-standing standard padding bug: plaintext ending with
	  bytes between 0x00 and 0x0A would be truncated in some conditions.
	- Fixed Rijndael_compat padding.

2.36    Wed 03 Feb 2021 09:19:06 AM EST
        - Add support for OFB, CFB and CTR chain modes.
	- New dependency: Math::BigInt

2.35    Sun Jan 31 22:02:42 EST 2021
        - Add support for PBKDF2 key derivation algorithm
	- New dependencies: Digest::SHA, Crypt::PBKDF2, Crypt::Cipher::AES

2.34    Fri Jan 29 18:08:12 EST 2021
        - Support for openssl SHA-256 key derivation algorithm
   2020-08-31 20:13:29 by Thomas Klausner | Files touched by this commit (3631) | Package updated
Log message:
*: bump PKGREVISION for perl-5.32.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0