./wip/libvips, Libvips is a demand-driven, horizontally threaded image processing lib

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 8.6.4, Package name: libvips-8.6.4, Maintainer: base

libvips is a 2D image processing library. Compared to similar libraries, libvips
runs quickly and uses little memory. libvips is licensed under the LGPL 2.1+

It has around 300 operations covering arithmetic, histograms, convolutions,
morphological operations, frequency filtering, colour, resampling, statistics
and others. It supports a large range of numeric formats, from 8-bit int to
128-bit complex. It supports a good range of image formats, including JPEG,
TIFF, PNG, WebP, FITS, Matlab, OpenEXR, DeepZoom, and OpenSlide. It can also
load images via ImageMagick or GraphicsMagick.

It has APIs for C and C++ and comes with a Python binding and a command-line
interface. Bindings are available for Ruby, JavaScript and others.


Required to run:
[textproc/libxml2] [graphics/libexif] [graphics/png] [graphics/jpeg] [devel/glib2]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 4a44659d8843251342378472da17d2bac00cbc26
RMD160: 80770fe6e1a52c9d334736597b749fea60e043f0
Filesize: 11891.243 KB

Version history: (Expand)