./wip/py-simplegeneric, Simple generic functions for Python

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.8.1, Package name: py27-simplegeneric-0.8.1, Maintainer: kamelderouiche

The simplegeneric module lets you define simple single-dispatch generic
functions, akin to Python's built-in generic functions like len(), iter()
and so on. However, instead of using specially-named methods,these
generic functions use simple lookup tables, akin to those used by e.g.
pickle.dump() and other generic functions found in
the Python standard library


Required to run:
[devel/py-setuptools] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 5acde1287e8368a44d2ef0b8f15e348bbfdc9f1c
RMD160: a464ef9b3dc774be8d13c0578c15c17dfd392eb0
Filesize: 12.366 KB

Version history: (Expand)


CVS history: (Expand)


   2015-07-15 20:20:12 by Thomas Klausner | Files touched by this commit (4)
Log message:
Switch zpl -> zpl-2.0 to follow rename of the license file in pkgsrc.
   2014-06-01 14:49:35 by Thomas Klausner | Files touched by this commit (208)
Log message:
Remove FETCH_USING.
It is a user-defined variable and should NOT be set in Makefiles.
   2014-02-10 22:25:10 by Kamel Derouiche | Files touched by this commit (1) | Package updated
Log message:
Update Maintainer

   2013-11-30 18:21:42 by Kamel Derouiche | Files touched by this commit (2) | Package updated
Log message:
Update Makefile

   2012-10-07 15:57:25 by Aleksej Saushev | Files touched by this commit (211)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Mark packages that don't or might probably not have staged installation.
   2011-12-28 23:48:58 by Kamel Derouiche | Files touched by this commit (1)
Log message:
fix: EGG_INFODIR stability

   2011-12-28 23:41:47 by Kamel Derouiche | Files touched by this commit (1) | Package updated
Log message:

 Update
   2011-12-28 23:38:56 by Kamel Derouiche | Files touched by this commit (2) | Package updated
Log message:

	update 0.7 --> 0.8

	o Update HOMEPAGE
	o Update COMMENT
	o Change license: apache-2.0 to zpl