./www/ruby-jekyll-gist, Liquid tag for displaying GitHub Gists in Jekyll sites

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.5.0, Package name: ruby24-jekyll-gist-1.5.0, Maintainer: pkgsrc-users

Liquid tag for displaying GitHub Gists in Jekyll sites.


Required to run:
[shells/bash] [devel/ruby-octokit] [lang/ruby24-base]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: efc7cce6645e638cca64b2044b1a9796588aa287
RMD160: e3121172e0bd6b698d4bc3228185ef3fa170963a
Filesize: 12 KB

Version history: (Expand)


CVS history: (Expand)


   2018-03-13 18:39:48 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
www/ruby-jekyll-gist: update to 1.5.0

1.5.0						2017/12/03

Documentation

* replace 'plugins' key in config with 'gems' (#46)
* Docs: Remove username in gist (#54)

Development Fixes

* Remove testing for Jekyll 2.x
* Requires Ruby > 2.1
* Add release script
* Inherit Jekyll's rubocop config for consistency (#48)
* define path with dir (#47)

1.4.1						2017/06/21

* Don't ask .empty? until it's a String. (#38)
* rename Liquid 4 has_key? to key? to add compatibility for liquid 4 (#41)
* Test against Ruby 2.1 to 2.4 (#45)
   2018-01-01 23:30:04 by Roland Illig | Files touched by this commit (537)
Log message:
Sort PLIST files.

Unsorted entries in PLIST files have generated a pkglint warning for at
least 12 years. Somewhat more recently, pkglint has learned to sort
PLIST files automatically. Since pkglint 5.4.23, the sorting is only
done in obvious, simple cases. These have been applied by running:

  pkglint -Cnone,PLIST -Wnone,plist-sort -r -F
   2017-09-11 18:03:17 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-jekyll-gist to 1.4.1.

## 1.4.1 / 2017-06-21

  * Don't ask .empty? until it's a String. (#38)
  * rename Liquid 4 `has_key?` to `key?` to add compatibility for liquid 4 (#41)
  * Test against Ruby 2.1 to 2.4 (#45)
   2015-12-13 17:51:30 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-jekyll-gist to 1.4.0.

## 1.4.0 / 2015-12-01

  * Allow `noscript` fallback to be disabled (#29)
  * Use Octokit to fetch Gist content when passed `JEKYLL_GITHUB_TOKEN`
    in env(#28)

## 1.3.5 / 2015-10-23

  * Fix encoding error for `noscript` code (#23)
  * Test against Jekyll 3, 2, and the github-pages gem (#19)
   2015-11-04 03:47:43 by Alistair G. Crooks | Files touched by this commit (758)
Log message:
Add SHA512 digests for distfiles for www category

Problems found locating distfiles:
	Package haskell-cgi: missing distfile haskell-cgi-20001206.tar.gz
	Package nginx: missing distfile array-var-nginx-module-0.04.tar.gz
	Package nginx: missing distfile encrypted-session-nginx-module-0.04.tar.gz
	Package nginx: missing distfile headers-more-nginx-module-0.261.tar.gz
	Package nginx: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package nginx-devel: missing distfile echo-nginx-module-0.58.tar.gz
	Package nginx-devel: missing distfile form-input-nginx-module-0.11.tar.gz
	Package nginx-devel: missing distfile lua-nginx-module-0.9.16.tar.gz
	Package nginx-devel: missing distfile nginx_http_push_module-0.692.tar.gz
	Package nginx-devel: missing distfile set-misc-nginx-module-0.29.tar.gz
	Package php-owncloud: missing distfile owncloud-8.2.0.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-09-13 17:33:16 by Takahiro Kambe | Files touched by this commit (2) | Package updated
Log message:
Update ruby-jekyll-gist to 1.3.4.

## 1.3.4 / 2015-08-28

  * Catch `TimeoutError` to further support 1.9.3 (#16)

## 1.3.3 / 2015-08-20

  * Fix gemspec to allow Ruby 1.9.3 (relates to #14)

## 1.3.2 / 2016-08-19

  * Re-add support for Ruby 1.9.3. Fixes #11 for 1.9.3 (#14)
  * Replaced `OpenURI` with `Net::HTTP` and introduced timeout of 3 seconds (#11)

## 1.3.1 / 2015-08-16 (yanked)

  * Replaced `OpenURI` with `Net::HTTP` and introduced timeout of 3 seconds (#11)

## 1.3.0 / 2015-08-05

  * Added an `noscript` fallback for browsers without JavaScript enabled. (#7)
   2015-06-11 18:52:26 by Takahiro Kambe | Files touched by this commit (3) | Package updated
Log message:
Update ruby-jekyll-gist to 1.2.1.

## 1.2.1 / 2015-03-22

  * Use `has_key?` (#6)

## 1.2.0 / 2015-03-21

### Minor Enhancements

  * Allow variables as parameters (#4)

### Development Fixes

  * Fix RSpec deprecation warning (#5)
   2015-03-13 17:44:56 by Takahiro Kambe | Files touched by this commit (4)
Log message:
Add ruby-jekyll-gist package version 1.1.0.

Liquid tag for displaying GitHub Gists in Jekyll sites.