./x11/mate-screensaver, Screen saver and locker for the MATE desktop

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.20.0nb1, Package name: mate-screensaver-1.20.0nb1, Maintainer: youri

mate-screensaver is a screen saver and locker that aims to have
simple, sane, secure defaults and be well integrated with the desktop.
It is designed to support:

* the ability to lock down configuration settings
* translation into many languages
* user switching


Required to run:
[sysutils/desktop-file-utils] [sysutils/dbus-glib] [sysutils/libnotify] [security/pam-pwauth_suid] [devel/glib2] [x11/libXScrnSaver] [sysutils/consolekit] [lang/python27] [x11/gtk3] [x11/mate-desktop] [x11/libmatekbd] [x11/mate-menus]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

SHA1: e92303ccfa7bfc6b9f62390852d65b8b0318cab7
RMD160: bf164cf5fd28f2682db2126387434e5bcdfd1352
Filesize: 4815.27 KB

Version history: (Expand)


CVS history: (Expand)


   2018-06-26 10:58:49 by Jonathan Perkin | Files touched by this commit (1) | Package updated
Log message:
mate-screensaver: Make the non-pam build actually work.

Bump PKGREVISION.
   2018-06-01 16:28:28 by Youri Mouton | Files touched by this commit (1)
Log message:
Remove double inclusion of prefs.mk.
   2018-05-14 15:14:01 by Youri Mouton | Files touched by this commit (2) | Package updated
Log message:
Update to 1.20.0:

OpenBSD authentication is supported in MATE Screensaver

Full changelog:

Add HiDPI support for lock screen
gs-lock-plug.c: Fix build warning:
WidthOfScreen and HeightOfScreen implementation
restore the correct mate-screensaver-command manpage
fix loop initial declarations
Fix: idle slider display in all languages
drop glib required max version
avoid deprecated gdk_screen_get_width/height
don’t use deprecated gtk_show_uri
Implement OpenBSD authentication using bsd_auth(3).
Bug Fix: g_get_real_name will never return NULL pointer
lock-dialog UI: avoid deprecated widgets
Bug fix: screensaver and lock screen not correctly displayed in configurations \ 
with overlapping monitor geometries
[GTK+3.20] Switch to GdkSeat
Set input purpose for the password entry widget
copy theme dialog: fix build warning about wrong variable type
Translations update
   2018-04-16 16:35:28 by Thomas Klausner | Files touched by this commit (1284)
Log message:
Recursive bump for new fribidi dependency in pango.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2017-11-23 18:20:22 by Thomas Klausner | Files touched by this commit (556)
Log message:
recursive bump for libxkbcommon removal from at-spi2-core
   2017-06-28 18:12:53 by Jonathan Perkin | Files touched by this commit (1)
Log message:
Restore PLIST.pam support.
   2017-06-28 18:12:09 by Jonathan Perkin | Files touched by this commit (1)
Log message:
Requires libXScrnSaver.