./databases/hiredis, Minimalistic C client library for the Redis database

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.0.2, Package name: hiredis-1.0.2, Maintainer: wiedi

Hiredis is a minimalistic C client library for the Redis database.

It is minimalistic because it just adds minimal support for the
protocol, but at the same time it uses an high level printf-alike
API in order to make it much higher level than otherwise suggested
by its minimal code base and the lack of explicit bindings for
every Redis command.

Apart from supporting sending commands and receiving replies, it
comes with a reply parser that is decoupled from the I/O layer. It
is a stream parser designed for easy reusability, which can for
instance be used in higher level language bindings for efficient
reply parsing.

Hiredis only supports the binary-safe Redis protocol, so you can
use it with any Redis version >= 1.2.0.

The library comes with multiple APIs. There is the synchronous API,
the asynchronous API and the reply parsing API.


Required to build:
[pkgtools/cwrappers]

Master sites:

Filesize: 95.839 KB

Version history: (Expand)


CVS history: (Expand)


   2021-10-26 12:10:08 by Nia Alarie | Files touched by this commit (417)
Log message:
databases: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

The following distfiles could not be fetched (some may be only fetched
conditionally):

./databases/cstore/distinfo D6.data.ros.gz
./databases/cstore/distinfo cstore0.2.tar.gz
./databases/cstore/distinfo data4.tar.gz
   2021-10-08 08:46:02 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
hiredis: updated to 1.0.2

1.0.2:
Announcing Hiredis v1.0.2, which fixes CVE-2021-32765 but returns the SONAME to \ 
the correct value of 1.0.0.
   2021-10-07 15:35:53 by Nia Alarie | Files touched by this commit (417)
Log message:
databases: Remove SHA1 distfile hashes
   2021-10-05 14:14:54 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
hiredis: updated to 1.0.1

1.0.1
Fix for CVE-2021-32765 commit
   2021-06-23 21:35:44 by Adam Ciarcinski | Files touched by this commit (4) | Package updated
Log message:
hiredis: updated to 1.0.0

Release of v1.0.0

Hiredis v1.0.0 marks the first stable release of Hiredis and introduces
RESP3 support, SSL connections, allocator injection, better Windows support,
and more.

IMPORTANT:  There are breaking changes in this release meaning your code
will need to be recompiled and may need small changes.  The exact
details of the breaking changes can be found in README.md.

CHANGELOG.md has a detailed list of changes between v0.14.1 and v1.0.0.
   2020-03-22 19:20:12 by Thomas Klausner | Files touched by this commit (4) | Package updated
Log message:
hiredis: update to 0.14.1.

### 0.14.1 (2020-03-13)

* Adds safe allocation wrappers (CVE-2020-7105, #747, #752) (Michael Grunder)
   2019-11-26 13:43:42 by Thomas Klausner | Files touched by this commit (3) | Package updated
Log message:
hiredis: update to 0.14.0.

### 0.14.0

**Fixes**:

* Catch a buffer overflow when formatting the error message
* Import latest upstream sds. This breaks applications that are linked against \ 
the old hiredis v0.13
* Fix warnings, when compiled with -Wshadow
* Make hiredis compile in Cygwin on Windows, now CI-tested
* Bulk and multi-bulk lengths less than -1 or greater than `LLONG_MAX` are now
  protocol errors. This is consistent with the RESP specification. On 32-bit
  platforms, the upper bound is lowered to `SIZE_MAX`.

**BREAKING CHANGES**:

* Change `redisReply.len` to `size_t`, as it denotes the the size of a string

User code should compare this to `size_t` values as well.
If it was used to compare to other values, casting might be necessary or can be \ 
removed, if casting was applied before.

* Remove backwards compatibility macro's

This removes the following old function aliases, use the new name now:

| Old                         | New                    |
| --------------------------- | ---------------------- |
| redisReplyReaderCreate      | redisReaderCreate      |
| redisReplyReaderCreate      | redisReaderCreate      |
| redisReplyReaderFree        | redisReaderFree        |
| redisReplyReaderFeed        | redisReaderFeed        |
| redisReplyReaderGetReply    | redisReaderGetReply    |
| redisReplyReaderSetPrivdata | redisReaderSetPrivdata |
| redisReplyReaderGetObject   | redisReaderGetObject   |
| redisReplyReaderGetError    | redisReaderGetError    |

* The `DEBUG` variable in the Makefile was renamed to `DEBUG_FLAGS`

Previously it broke some builds for people that had `DEBUG` set to some \ 
arbitrary value,
due to debugging other software.
By renaming we avoid unintentional name clashes.

Simply rename `DEBUG` to `DEBUG_FLAGS` in your environment to make it working again.
   2018-01-26 10:33:31 by Jonathan Perkin | Files touched by this commit (2)
Log message:
hiredis: Fix SunOS linker flags.