./devel/lua-compat53, Compatibility module providing Lua-5.3-style APIs for Lua 5.2 and 5.1

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.9, Package name: lua53-compat53-0.9, Maintainer: pkgsrc-users

This is a small module that aims to make it easier to write Lua
code in a Lua-5.3-style that runs on Lua 5.1+.

It does *not* make Lua 5.2 (or even 5.1) entirely compatible
with Lua 5.3, but it brings the API closer to that of Lua 5.3.


Required to run:
[lang/lua53]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: e1f2f8052dacb30295c768969547423c882bf3ee
RMD160: ae80f773f517885dad3e64863aaf9b56d40d535c
Filesize: 52.343 KB

Version history: (Expand)


CVS history: (Expand)


   2020-07-11 15:48:49 by Nia Alarie | Files touched by this commit (4) | Package updated
Log message:
lua-compat53: Update to 0.9

This update makes it possible to use the module with Lua 5.4.

I added support for testing, but this doesn't seem particularly
useful for non-developers since its output is obscure, but it
can at least be used to demonstrate that the module loads and
the tests don't fail to run.
   2020-07-08 16:25:38 by Nia Alarie | Files touched by this commit (6)
Log message:
devel: Add lua-compat53. Based on work by Jonathan Buschmann in wip.

This is a small module that aims to make it easier to write Lua
code in a Lua-5.3-style that runs on Lua 5.3, 5.2, and 5.1.

It does *not* make Lua 5.2 (or even 5.1) entirely compatible
with Lua 5.3, but it brings the API closer to that of Lua 5.3.