./devel/p5-Class-Load, Provide a working (require Class::Name) and more

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.25nb3, Package name: p5-Class-Load-0.25nb3, Maintainer: pkgsrc-users

require EXPR only accepts Class/Name.pm style module names, not
Class::Name. How frustrating! For that, we provide load_class
'Class::Name'.

It's often useful to test whether a module can be loaded, instead
of throwing an error when it's not available. For that, we provide
try_load_class 'Class::Name'.

Finally, sometimes we need to know whether a particular class has
been loaded. Asking %INC is an option, but that will miss inner
packages and any class for which the filename does not correspond
to the package name. For that, we provide is_class_loaded 'Class::Name'.


Required to run:
[lang/perl5] [devel/p5-Data-OptList] [devel/p5-Try-Tiny] [devel/p5-Package-Stash] [devel/p5-Module-Runtime] [devel/p5-Module-Implementation]

Required to build:
[devel/p5-Test-Requires] [devel/p5-Test-Fatal] [pkgtools/cwrappers] [devel/p5-Test-Needs]

Master sites: (Expand)

SHA1: f800087a2b04c1ffdb51c05c2c1a25d8770b0189
RMD160: 1da287cd47a569c7b9c72cad85f949c52f488968
Filesize: 35.785 KB

Version history: (Expand)


CVS history: (Expand)


   2020-08-31 20:13:29 by Thomas Klausner | Files touched by this commit (3631) | Package updated
Log message:
*: bump PKGREVISION for perl-5.32.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-06-18 04:56:13 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.25

Upstream changes:
0.25     2018-06-10 20:55:10Z
    - merged required and recommended Data::OptList version prerequisite, to
      work around CPAN.pm bug (RT#123447)
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-04-14 16:58:08 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-Class-Load to 0.24
-----------------------------------
0.24     2017-04-10 21:12:31Z
    - fix test to handle altered Test::Without::Module exception message
      (PR#2, Paul Howarth)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.