./devel/p5-Git-Version-Compare, Functions to compare Git versions

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.004nb3, Package name: p5-Git-Version-Compare-1.004nb3, Maintainer: pkgsrc-users

Git::Version::Compare contains a selection of subroutines that make
dealing with Git-related things (like versions) a little bit easier.

The strings to compare can be version numbers, tags from git.git or
the output of git version or git describe.


Required to run:
[lang/perl5]

Required to build:
[devel/p5-Test-NoWarnings] [devel/p5-namespace-clean] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 74895fffdacf044ddc8f27c248523d4780ae30a3
RMD160: 97a58dbec124f4f30b2d37afc5e366f9444b5ae5
Filesize: 17.353 KB

Version history: (Expand)


CVS history: (Expand)


   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-19 13:57:38 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
(pkgsrc)
 - Add following line for make test
  BUILD_DEPENDS+=        p5-Test-NoWarnings-[0-9]*:../../devel/p5-Test-NoWarnings

(upstream)
 - Updated devel/p5-Git-Version-Compare to 1.004
---------------------------------------------
1.004 2016-05-24 BOOK
    - Remove a dependency on namespace::clean
    - Update the cache using the normalized version string
    - Ignore minor versions of special builds (msysgit, windows, etc.)
    - Ensure the tests do not throw any warning
    - Add a few more version numbers to the tests

1.003 2016-05-03 BOOK
    - Added support for version strings with comments (thanks to PINE)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.
   2016-05-03 14:03:42 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated to devel/p5-Git-Version-Compare 1.002
---------------------------------------------
1.002 2016-04-27 BOOK
    - Increased the test coverage (from ~400 to ~11000 unit tests)
   2016-04-14 15:41:42 by Makoto Fujiwara | Files touched by this commit (1)
Log message:
- Add following line for make test
   +# for make test
   +BUILD_DEPENDS+=        p5-namespace-clean-[0-9]*:../../devel/p5-namespace-clean