./devel/p5-Module-CPANTS-Analyse, Perl5 module to generate Kwalitee ratings for a distribution

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.01, Package name: p5-Module-CPANTS-Analyse-1.01, Maintainer: pkgsrc-users

Module::CPANTS::Analyse - Generate Kwalitee ratings for a distribution.


Required to run:
[textproc/p5-YAML-Syck] [www/p5-libwww] [lang/perl5] [devel/p5-Class-Accessor] [devel/p5-IO-Capture] [devel/p5-List-MoreUtils] [devel/p5-Module-Pluggable] [devel/p5-Set-Scalar] [devel/p5-Readonly] [devel/p5-Module-Find] [devel/p5-CPAN-DistnameInfo] [devel/p5-Test-YAML-Meta] [devel/p5-Array-Diff] [devel/p5-Module-ExtractUse] [devel/p5-Software-License] [devel/p5-File-Find-Rule-VCS] [archivers/p5-Archive-Any-Lite] [devel/p5-ExtUtils-MakeMaker-CPANfile] [devel/p5-Data-Binary] [devel/p5-Perl-PrereqScanner-NotQuiteLite]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 8b9cd8b4b978ca57ab3ef7ac5b54e7bab03e253e
RMD160: bf06ec5a46f136a75f3516e055caa958c70019cd
Filesize: 38.018 KB

Version history: (Expand)


CVS history: (Expand)


   2019-10-26 09:19:26 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
(devel/p5-Module-CPANTS-Analyse)  Updated 1.00 to 1.01

1.01 2019-08-08
  - Fixed not to set an error message when extracted nicely
    (spotted by Martin Becker++)
  - Fixed to restore mtime of MANIFEST.SKIP if it is modified by
    #include_default
  - Improved primary module detection
  - Fixed to catch CPAN::Meta::YAML's warnings (of duplicate keys)
  - Improved test_prereqs_match to handle t::lib::Util, and ignore
    files that contain but don't end with .t
  - Fixed to store multiple licenses in META files
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2019-02-09 09:26:10 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 1.00
Add missing DEPENDS

Upstream changes:
1.00 2019-02-03
  ** BACKWARD INCOMPATIBLE CHANGE **
  - Module::CPANTS::Kwalitee::Uses now uses a different prereq scanner
    (Perl::PrereqScanner::NotQuiteLite).
  - Added new kwalitee metrics:
    no_maniskip_error, no_missing_files_in_provides, no_files_to_be_skipped
  - Delayed plugin loading
   2019-01-26 09:19:53 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.99
Add missing DEPENDS

Upstream changes:
0.99 2019-01-15
  - requires Module::Find

0.98 2019-01-15
  ** BACKWARD INCOMPATIBLE (INTERNAL) CHANGE **
  - Module::CPANTS::Kwalitee now uses Module::Find to find
    Kwalitee modules (instead of Module::Pluggable that unconditonally
    spits a deprecation warning). You usually don't need to care
    but if you have your custom Kwalitee plugin loader (such as
    Module::CPANTS::SiteKwalitee), you need to change it.
    Sorry for the inconvenience.

  - Allow dash and dot in script name in the NAME section for
    non-pm, non-pod files

0.97_11 2018-04-22
  - no changes; for testing

0.97_10 2018-04-22
  - no changes; for testing

0.97_09 2018-04-22
  - no changes; for testing

0.97_08 2018-04-22
  - no changes; for testing

0.97_07 2018-04-22
  - no changes; for testing

0.97_06 2018-04-22
  - no changes; for testing

0.97_05 2018-04-22
  - no changes; for testing

0.97_04 2018-04-21
  - Skip everything in MANIFEST.SKIP while testing symlinks (GH#33, Tux++)

0.97_03 2016-09-01
  - Not to check use_strict/use_warnings for Perl 6 modules in a
    Perl 5 distribution (Stefan Seifert++)
  - Worked around a File::Find::Object issue (reported by dolmen)
  - Fixed dynamic_config handling (David Golden++)
  - Improved LICENSE file detection (RT#114247)

0.97_02 2016-04-27
  - Requires List::Util 1.33

0.97_01 2016-04-24
  - Added has_meta_json metric (RT#107885)
  - Accept a few more README extensions (mrcaron)
  - Accept two more Moose modules as strict equivalents
  - Various micro optimization for performance
  - Dropped a few dependencies
  - Doc patch from brac-mac and joenio
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.