./devel/p5-Mojo-IOLoop-Delay, Promises/A+ and flow-control helpers (deprecated)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 8.76, Package name: p5-Mojo-IOLoop-Delay-8.76, Maintainer: pkgsrc-users

Mojo::IOLoop::Delay adds flow-control helpers to Mojo::Promise,
which can help you avoid deep nested closures that often result
from continuation-passing style.

This module has been extracted from Mojolicious and was removed
from it at the 9.0 release. It is kept here for backwards compatibility
purposes but there is no intention to maintain it further and it
should be migrated away from as your earliest convenience.

Though there is no intention of removing it from CPAN in the future
it should be treated as deprecated and the metadata will mark it
as such. It will receive no no-security-related changes going
forward.


Master sites:

Filesize: 8.678 KB

Version history: (Expand)


CVS history: (Expand)


   2022-08-25 12:26:13 by David Brownlee | Files touched by this commit (3)
Log message:
Really add p5-Mojo-IOLoop-Delay-8.76

(Will fixup p5-Mojo-IOLoop-ForkCall next)

Mojo::IOLoop::Delay adds flow-control helpers to Mojo::Promise,
which can help you avoid deep nested closures that often result
from continuation-passing style.

This module has been extracted from Mojolicious and was removed
from it at the 9.0 release. It is kept here for backwards compatibility
purposes but there is no intention to maintain it further and it
should be migrated away from as your earliest convenience.

Though there is no intention of removing it from CPAN in the future
it should be treated as deprecated and the metadata will mark it
as such. It will receive no no-security-related changes going
forward.