./devel/p5-MooseX-Types-Stringlike, Commonly-used type constraints that do not ship with Moose by default

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.003nb6, Package name: p5-MooseX-Types-Stringlike-0.003nb6, Maintainer: pkgsrc-users

This module provides a more general version of the Str type. If coercions
are enabled, it will accepts objects that overload stringification and
coerces them into strings.


Required to run:
[lang/perl5] [devel/p5-MooseX-Types]

Required to build:
[devel/p5-Package-DeprecationManager] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: a76fbd214d059039032d00618c2a71f58dc85f67
RMD160: a3cd41f1d1e050f92a20ddf94c078434ebd28f5f
Filesize: 13.193 KB

Version history: (Expand)


CVS history: (Expand)


   2020-08-31 20:13:29 by Thomas Klausner | Files touched by this commit (3631) | Package updated
Log message:
*: bump PKGREVISION for perl-5.32.
   2019-11-03 11:16:06 by Roland Illig | Files touched by this commit (152)
Log message:
devel/p5-*: align variable assignments

pkglint -Wall -F --only aligned --only indent p5-*

No manual corrections.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-04-18 15:57:14 by Makoto Fujiwara | Files touched by this commit (1)
Log message:
 Add BUILD_DEPENDS+= p5-Package-DeprecationManager-[0-9]* for make test
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.