./devel/p5-multidimensional, Perl 5 module to disable multidmensional array emulation

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.014nb2, Package name: p5-multidimensional-0.014nb2, Maintainer: pkgsrc-users

Perl's multidimensional array emultaion stems from the days before
the language had references, but these days it mostly serves to bite
you when you typo a hash slice by using the $ sigil instead of @.

This module lexically makes using multidmensional array emulation a
fatal error at compile time.


Required to run:
[lang/perl5] [devel/p5-B-Hooks-OP-Check]

Required to build:
[devel/p5-ExtUtils-Depends] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: 59bb25a7aa9a7d3cf3cebdd5d63f46b419b1aab0
RMD160: 1c80cad36ef335efcad3dec18660e84b3223cf0c
Filesize: 65.398 KB

Version history: (Expand)


CVS history: (Expand)


   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-05-02 14:22:25 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-multidimensional: update to 0.014.

0.014     2018-04-26 22:35:46+01:00 Europe/London
 - Only use Lexical::SealRequireHints before perl 5.12
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-04-22 08:27:45 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
Updated devel/p5-multidimensional to 0.013
------------------------------------------
0.013     2017-04-20 15:05:14+01:00 Europe/London
 - Switch to Dist::Zilla::PluginBundle::Starter
   and ::Plugin::DymamicPrereqs
 - Use Devel::PPPort insted of hand-rolled compat macros
   2016-07-15 09:51:30 by Wen Heping | Files touched by this commit (2) | Package updated
Log message:
Update to 0.012

Upstream changes:
0.012     2016-05-16 19:18:11+01:00 Europe/London
  - Use "multidimensional/disabled" as the hints hash key
  - Fix building on -DPERL_OP_PARENT perls (RT#114395)
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.