./devel/sdl12-compat, SDL-1.2 compatibility layer that uses SDL 2.0 behind the scenes

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.2.52nb2, Package name: sdl12-compat-1.2.52nb2, Maintainer: nia

This is the Simple DirectMedia Layer, a general API that provides low level
access to audio, keyboard, mouse, joystick, 3D hardware via OpenGL, and 2D
framebuffer across multiple platforms.

This code is a compatibility layer; it provides a binary and source compatible
API for programs written against SDL 1.2, but it uses SDL 2.0 behind the
scenes. If you are writing new code, please target SDL 2.0 directly and do
not use this layer.


Master sites:

Filesize: 411.178 KB

Version history: (Expand)


CVS history: (Expand)


   2022-09-11 14:52:13 by Thomas Klausner | Files touched by this commit (670)
Log message:
*: bump PKGREVISION for flac shlib bump
   2022-08-11 07:09:36 by David H. Gutteridge | Files touched by this commit (999)
Log message:
Bump all dependent packages of wayland (belatedly)

The package changed with the addition of its libepoll-shim dependency.
Otherwise, we can get:
ERROR: libepoll-shim>=0.0.20210418 is not installed; can't buildlink files.
   2022-04-21 08:56:19 by Nia Alarie | Files touched by this commit (2)
Log message:
sdl12-compat: needs glu on !darwin
   2022-04-02 09:17:55 by Nia Alarie | Files touched by this commit (2)
Log message:
Add CONFLICTS for sdl12-compat.
   2022-04-01 12:43:05 by Nia Alarie | Files touched by this commit (7)
Log message:
devel: add sdl12-compat

This is the Simple DirectMedia Layer, a general API that provides low level
access to audio, keyboard, mouse, joystick, 3D hardware via OpenGL, and 2D
framebuffer across multiple platforms.

This code is a compatibility layer; it provides a binary and source compatible
API for programs written against SDL 1.2, but it uses SDL 2.0 behind the
scenes. If you are writing new code, please target SDL 2.0 directly and do
not use this layer.