./editors/xemacs-nox11, XEmacs text editor version 21.4 (no x11 support)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 21.4.24nb16, Package name: xemacs-nox11-21.4.24nb16, Maintainer: hauke

XEmacs is a self-documenting, customizable, extensible real-time
display editor.

Users new to XEmacs will be able to use basic features fairly rapidly
by studying the tutorial and using the self-documentation features.
XEmacs also has an extensive interactive manual browser. It is easily
extensible since its editing commands are written in Lisp.

XEmacs's many special packages handle mail reading (RMail) and sending
(Mail), outline editing (Outline), compiling (Compile), running
subshells within Emacs windows (Shell), running a Lisp read-eval-print
loop (Lisp-Interaction-Mode), automated psychotherapy (Doctor :-) and
many more. There is a WWW browsing mode written fully in elisp
that looks and behaves much like the netscape WWW browser.

XEmacs has similar functionality to GNU Emacs. It uses a different
display model, including support for Motif menu and scroll bars and the
ability to run as a widget inside other applications. Many people say
it looks nicer than GNU Emacs.

This package does not support X11.


Required to run:
[databases/gdbm]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)


Version history: (Expand)


CVS history: (Expand)


   2021-10-03 19:53:11 by Hauke Fath | Files touched by this commit (8)
Log message:
For the sake of MKPIE, we need to .include Makefile.common before
options.mk.

Since Makefile.common now does not see the x11 option, we have to move
all x11 related commands into options.mk. Within options, move
.includes to the end for consistency.
   2021-03-28 12:36:33 by Hauke Fath | Files touched by this commit (10)
Log message:
Use gtar instead of the base tar(1) in the xemacs* top-level Makefile
because of a problem with NetBSD-current libarchive-as-tar, see bin/56080.

Note this depencency is not a burden, since xemacs-packages requires
gtar, anyway.
   2020-10-02 13:31:14 by Hauke Fath | Files touched by this commit (8)
Log message:
Linux glibc 2.32+ has removed sys_siglist

Remove stale reference to nb version in Makefile.common
   2020-08-31 20:13:29 by Thomas Klausner | Files touched by this commit (3631) | Package updated
Log message:
*: bump PKGREVISION for perl-5.32.
   2019-11-27 15:35:16 by Hauke Fath | Files touched by this commit (7)
Log message:
For Solarish, select _XOPEN_SOURCE version depending on __STDC_VERSION__,
see <https://gist.github.com/jperkin/b08f9108daf8d0ac695067d71f882a9d>
   2019-10-11 16:42:48 by Hauke Fath | Files touched by this commit (6)
Log message:
Sorry, barked up the wrong tree.

gtexinfo 6.7 appears to default to utf8, and error out on non-7bit
ascii gremlins. Fixing those lets the texinfo files compile (with
warnings) both with the NetBSD base makeinfo and the v6.7 pkgsrc one.

OTOH, I don't have to remove the patches I forgot to add in the
previous commit...
   2019-10-11 14:36:44 by Hauke Fath | Files touched by this commit (4) | Package updated
Log message:
This package patches the texinfo sources for use with NetBSD's
makeinfo v4.8. The 6.7 update to devel/gtexinfo broke backwards
compatibility more, so we pull out the patches and conditionally apply
them on NetBSD, only. (Other candidates?)
   2019-10-08 14:40:55 by Hauke Fath | Files touched by this commit (6)
Log message:
Declare use of perl.