./emulators/compat90, Shared libraries for NetBSD 9.0 compatibility

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 9.0nb1, Package name: compat90-9.0nb1, Maintainer: pkgsrc-users

This package supplies the shared library files needed to run dynamically
linked executables compiled under NetBSD 9.0 on a later NetBSD.
The shared libraries for 'native' X11 are integrated.

This package is bridging the gap to NetBSD 10; since the latter is
still in beta at the time of creating this package, the package may
be incomplete.


Master sites: (Expand)


Version history: (Expand)


CVS history: (Expand)


   2022-01-02 17:54:05 by Havard Eidnes | Files touched by this commit (1)
Log message:
Update distinfo as well, to complete the EMUL_PLATFORMS renaming.
   2022-01-02 17:49:29 by Havard Eidnes | Files touched by this commit (8)
Log message:
Rename the set lists corresponding to recent EMUL_PLATFORMS
renaming.  Ride on recent PKG_REVISION bump.
   2022-01-02 17:35:12 by Havard Eidnes | Files touched by this commit (1)
Log message:
Adjust EMUL_PLATFORMS to pkglint's liking:
armeb -> earmeb
armv6hf -> earmv6hf
armv7hf -> earmv7hf
m68010 -> m68000
Compat symlinks created in distfile repository.
Riding on the quite recent PKGREVISION bump.
   2022-01-02 17:22:32 by Havard Eidnes | Files touched by this commit (1)
Log message:
Change the ONLY_FOR_PLATFORM pattern, so that it no longer matches
against 9.0, 9.1, 9.2 or 9.x_STABLE, only 9.99.* and subsequent
releses.  The set of libraries this is compared against is what's
in 9.99.92, but the binaries are from 9.0, of course.

Bump PKGREVISION so that we pick up the changes from
compat_netbsd/INSTALL.ELF, to protect against removal of base system
symlinks, ref. PR#56597.
   2021-12-18 11:36:03 by Havard Eidnes | Files touched by this commit (1)
Log message:
Correct the amd64 compat package checksum...
   2021-12-18 02:01:33 by Havard Eidnes | Files touched by this commit (25)
Log message:
Add an attempt at a compat90 package.