./fonts/tex-pxchfon, Japanese font setup for pLaTeX and upLaTeX

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.9, Package name: tex-pxchfon-1.9, Maintainer: pkgsrc-users

This package enables users to declare in their document which
physical fonts should be used for the standard Japanese
(logical) fonts of pLaTeX and upLaTeX. Font setup is realized
by changing the font mapping of dvipdfmx, and thus users can
use any (monospaced) physical fonts they like, once they
properly install this package, without creating helper files
for each new font. This package also supports setup for the
fonts used in the japanese-otf package. System requirements:
TeX format: LaTeX. TeX engine: pTeX or upTeX. DVIware:
dvipdfmx. Prerequisite packages: atbegshi.


Master sites: (Expand)


Version history: (Expand)


CVS history: (Expand)


   2022-04-15 06:31:17 by Mark Davies | Files touched by this commit (4) | Package updated
Log message:
tex-pxchfon{,-doc}: update to 1.9

- Support multi-weight settings for Chinese/Korean fonts.
- New option 'use' for simply loading map files.
   2021-10-26 12:28:41 by Nia Alarie | Files touched by this commit (864)
Log message:
fonts: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes
   2021-10-07 16:05:29 by Nia Alarie | Files touched by this commit (864)
Log message:
fonts: Remove SHA1 hashes for distfiles
   2021-02-21 09:53:28 by Mark Davies | Files touched by this commit (8)
Log message:
tex-pxchfon{,-doc}: Add version 1.7e

From Atsushi Toyokura in pkgsrc-wip

This package enables users to declare in their document which
physical fonts should be used for the standard Japanese
(logical) fonts of pLaTeX and upLaTeX. Font setup is realized
by changing the font mapping of dvipdfmx, and thus users can
use any (monospaced) physical fonts they like, once they
properly install this package, without creating helper files
for each new font. This package also supports setup for the
fonts used in the japanese-otf package. System requirements:
TeX format: LaTeX. TeX engine: pTeX or upTeX. DVIware:
dvipdfmx. Prerequisite packages: atbegshi.