./graphics/p5-GD, Perl5 interface to gd graphics library

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.71nb1, Package name: p5-GD-2.71nb1, Maintainer: pkgsrc-users

This is an autoloadable interface module for libgd, a popular library
for creating and manipulating PNG files. With this library you can
create PNG images on the fly or modify existing files. Features
include:

a. lines, polygons, rectangles and arcs, both filled and unfilled
b. flood fills
c. the use of arbitrary images as brushes and as tiled fill patterns
d. line styling (dashed lines and the like)
e. horizontal and vertical text rendering
f. support for transparency and interlacing


Required to run:
[graphics/gd] [lang/perl5]

Required to build:
[devel/p5-ExtUtils-PkgConfig] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: b1bbc5c55bdc80553fabf17b01a90e6be0f4886c
RMD160: 8cf166852315841ffbdf44afea5fb7e8c415457c
Filesize: 250.825 KB

Version history: (Expand)


CVS history: (Expand)


   2020-03-23 18:53:10 by Tobias Nygren | Files touched by this commit (1)
Log message:
p5-GD: needs ExtUtils::PkgConfig
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2019-02-24 01:52:58 by Makoto Fujiwara | Files touched by this commit (2) | Package updated
Log message:
graphics/p5-GD updated to 2.71

2.71    * skip Test::Fork on freebsd (GH #25)
2.70    * fixes for hardened CCFLAGS with -Werror (RT #128167)
   2018-08-29 07:52:58 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-GD: update to 2.69.

2.69    * little spelling error, GH #29 Xavier Guimard
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2018-02-25 18:45:46 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-GD: update to 2.68.

2.68    * fix GD::Polygon->clear, RT #124463 Michael Cain