./lang/gcc49, The GNU Compiler Collection (GCC) - 4.9 Release Series

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.9.4nb8, Package name: gcc49-4.9.4nb8, Maintainer: pkgsrc-users

The GNU Compiler Collection (GCC) includes front ends for C, C++, Objective-C,
Fortran, Java, and Go, as well as libraries for these languages (libstdc++,
libgcj,...).


Required to run:
[textproc/gsed] [math/mpfr] [devel/gmp] [math/mpcomplex]

Required to build:
[pkgtools/cwrappers]

Package options: gcc-c++, gcc-fortran, gcc-objc, gcc-objc++, nls

Master sites: (Expand)

SHA1: 5bb0b783a57a62b11f1f9bd2aa37145da221d3d0
RMD160: 180d4aaa9d2c34084f3f01261f8cb00ddb921529
Filesize: 87985.943 KB

Version history: (Expand)


CVS history: (Expand)


   2020-01-19 00:36:14 by Roland Illig | Files touched by this commit (3046)
Log message:
all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
   2019-11-03 20:04:09 by Roland Illig | Files touched by this commit (159)
Log message:
lang: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.
   2019-09-08 16:47:53 by Maya Rashish | Files touched by this commit (6)
Log message:
gcc{48,49,5,6,7,8}: In the case of a "system GCC", detect if the system
libgcc is newer than the one about to be installed. If so, don't install
the libgcc.

Having an older libgcc appear in the lookup may result in binaries not
running, as they need symbols from the newer libgcc.
Such a case is PR pkg/54506.

Leaves SunOS unchanged, by request from jperkin.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-08-06 08:16:16 by Maya Rashish | Files touched by this commit (12)
Log message:
gcc{48,49,5,6}: add patch to avoid fragile include guard logic
for ansi.h on netbsd.
gcc{7,8}: document same patch that already existed was upstreamed.

This patch is necessary to build GCC on NetBSD >= 9.0, since changes
to ansi.h resulted in not using the same include guards.

Fixes PR toolchain/54362
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-07-18 02:06:25 by Joerg Sonnenberger | Files touched by this commit (168)
Log message:
Mark packages that require C++03 (or the GNU variants) if they fail with
C++14 default language.
   2018-01-28 17:24:15 by Thomas Klausner | Files touched by this commit (71)
Log message:
recursive bump after mpfr shlib major bump