./lang/mozjs78, SpiderMonkey JavaScript library (78.x branch)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 78.4.0, Package name: mozjs78-78.4.0, Maintainer: pkgsrc-users

This directory contains SpiderMonkey 78, the JavaScript engine by
Mozilla.


Master sites:

SHA1: b2c1c241f70310d545f8a3c05b9c8c11676e56a8
RMD160: cef93b6116eff9f04beeaf3dda0a42cd811d0b18
Filesize: 56952.188 KB

Version history: (Expand)


CVS history: (Expand)


   2020-11-29 01:28:39 by David H. Gutteridge | Files touched by this commit (1)
Log message:
mozjs78: include bsd.prefs.mk so $MACHINE_PLATFORM is defined
   2020-11-28 12:02:15 by Nia Alarie | Files touched by this commit (3)
Log message:
mozjs78: Remove PYTHON3 hack, it's no longer needed
   2020-11-28 11:56:02 by Nia Alarie | Files touched by this commit (1)
Log message:
mozjs78: Remove EOL whitespace
   2020-11-28 11:54:55 by Nia Alarie | Files touched by this commit (3)
Log message:
mozjs78: Adapt he@'s mozjs60 powerpc patches
   2020-11-25 01:40:17 by David H. Gutteridge | Files touched by this commit (3)
Log message:
mozjs78: fix builds on some 32-bit architectures

As with earlier versions, this expects 64-bit atomic operations.
Separately, there's an issue with an assertion in test code that makes
an assumption about the size of an index variable vs. size_t that
doesn't hold.

Test suite comparisons between resultant amd64 and i386 builds on
recent NetBSD releases reveal a similar number of failures (18 vs. 20),
mostly to do with date parsing, though i386 also fails with two IEEE
754 double precision tests.

I did look at carrying mozjs60 patches for NetBSD/powerpc forward, but
I don't have a viable test environment at the moment, and code
inspection suggests that may not be straightforward.
   2020-11-21 03:42:03 by David H. Gutteridge | Files touched by this commit (1)
Log message:
mozjs78: requires minimum GCC 7.1
   2020-11-21 03:28:13 by David H. Gutteridge | Files touched by this commit (1)
Log message:
mozjs78: record correct minimum Rust version
   2020-11-12 11:26:54 by Nia Alarie | Files touched by this commit (1)
Log message:
mozjs78: Fix Python dependencies. Add py-expat.