./misc/libcdio-paranoia, CD-ROM access library: CDDA support

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.0.1nb1, Package name: libcdio-paranoia-2.0.1nb1, Maintainer: pkgsrc-users

Support for extracting audio from a CD in a jitter- and error-tolerant way.
Split off from libcdio to allow more flexible licensing and to be compatible
with cdparanoia-III-10.2's license. And also, libcdio is just too large.


Required to run:
[misc/libcdio] [lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites: (Expand)

SHA1: de30d968b6b16cefa43e9b071ede4bccb837644a
RMD160: bca30a237d1eb5c8e5fc15d1dfc171a01b8d879e
Filesize: 575.269 KB

Version history: (Expand)


CVS history: (Expand)


   2020-08-31 20:13:29 by Thomas Klausner | Files touched by this commit (3631) | Package updated
Log message:
*: bump PKGREVISION for perl-5.32.
   2020-08-25 16:40:19 by Thomas Klausner | Files touched by this commit (3) | Package updated
Log message:
libcdio-paranoia: update to 2.0.1.

10.2+2.0.1
---------
2019-09-16

- cdda toc routines now included (fixes #21)
- "make distcheck" broken in 2.0.0 works properly again
- Remove some gcc/clang warnings
   2020-01-19 00:36:14 by Roland Illig | Files touched by this commit (3046)
Log message:
all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-04-30 13:36:10 by Adam Ciarcinski | Files touched by this commit (2) | Package updated
Log message:
libcdio-paranoia: updated to 2.0.0

version 10.2+0.95
- Now works with audio CD's that start on a track greater than 1.
- OpenBSD tolerance
- typos in manual page and README
- Do not attempt to call a NULL callback

version 10.2+0.94+2
- Add --force-overread
  Force overreading into the lead-out portion of the disc. This option
  is only applicable when using the "-O" option with a positive sample
  offset value. Many drives are not capable of reading into this
  portion of the disc and attempting to do so on those drives will
  produce read errors and possibly hard lockups

version 10.2+0.94+1
- Fix problem where end of span seems to default to last track.
- Fix NULL pointer dereference that occurs when byte swapping is
  needed.
- Re-silence recently added gcc -Wunused-result warnings
- Use @LIBS@ figured out by autoconf when linking (for -lrt on Linux).
- Incorrect track was getting used in matching.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-08-19 22:16:42 by Thomas Klausner | Files touched by this commit (38)
Log message:
*: reset maintainer for drochner
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.