./multimedia/ffmpeg1, Decoding, encoding and streaming software (v1.x)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.2.12nb12, Package name: ffmpeg1-1.2.12nb12, Maintainer: pkgsrc-users

FFmpeg is a complete, cross-platform solution to record, convert
and stream audio and video. It includes libavcodec - the leading
audio/video codec library.

This package contains major version 1.


Required to run:
[multimedia/xvidcore] [multimedia/libtheora] [audio/lame] [audio/libvorbis] [multimedia/libvdpau] [multimedia/libva] [multimedia/libvpx] [multimedia/libass]

Required to build:
[pkgtools/x11-links] [devel/yasm] [pkgtools/cwrappers]

Package options: ass, lame, libvpx, theora, vaapi, vdpau, vorbis, xvid

Master sites:

SHA1: ae7328442046f2c92e7909e66e91034e8072c78b
RMD160: 38fd1f46a516310e80a7ea22ae09ef6968864d6f
Filesize: 5834.394 KB

Version history: (Expand)


CVS history: (Expand)


   2019-11-03 18:12:05 by Roland Illig | Files touched by this commit (52)
Log message:
multimedia: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

No manual corrections.
   2019-07-21 00:46:59 by Thomas Klausner | Files touched by this commit (595)
Log message:
*: recursive bump for nettle 3.5.1
   2018-11-23 09:06:34 by Ryo ONODERA | Files touched by this commit (66)
Log message:
Recursive revbump from multimedia/libva
   2018-11-12 04:53:16 by Ryo ONODERA | Files touched by this commit (1532)
Log message:
Recursive revbump from hardbuzz-2.1.1
   2018-07-04 15:40:45 by Jonathan Perkin | Files touched by this commit (423)
Log message:
*: Move SUBST_STAGE from post-patch to pre-configure

Performing substitutions during post-patch breaks tools such as mkpatches,
making it very difficult to regenerate correct patches after making changes,
and often leading to substituted string replacements being committed.
   2018-06-15 12:52:02 by Jonathan Perkin | Files touched by this commit (1)
Log message:
ffmpeg1: Remove x264 as a supported option.

This package shares a PKG_OPTIONS variable with the other ffmpeg
packages, so a user who requests the x264 option for them will end
up with a broken package for ffmpeg1.
   2018-05-16 13:09:57 by Jonathan Perkin | Files touched by this commit (1)
Log message:
ffmpeg1: Remove x264 from PKG_SUGGESTED_OPTIONS.

The current x264 version in pkgsrc has changed the API and ffmpeg1 no longer
builds against it.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.