./print/hplip, HP Linux Imaging and Printing

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.19.12nb14, Package name: hplip-3.19.12nb14, Maintainer: pkgsrc-users

HPLIP (Hewlett-Packard Linux Imaging & Printing) is an HP-developed
solution for printing, scanning, and faxing with HP inkjet and laser
based printers in Linux.

The HPLIP project provides printing support for 1,980 printer models,
including Deskjet, Officejet, Photosmart, PSC (Print Scan Copy),
Business Inkjet, LaserJet, Edgeline MFP, and LaserJet MFP. See [1]
for more information on supported printers.

[1] http://hplipopensource.com/hplip-web/supported_devices/index.html

MESSAGE.scan [+/-]

Required to run:
[sysutils/dbus] [sysutils/py-dbus] [print/ghostscript] [print/py-reportlab] [graphics/jpeg] [lang/perl5] [net/wget] [net/net-snmp] [security/openssl] [devel/libusb1] [print/cups-base]

Required to build:
[pkgtools/x11-links] [sysutils/dbus-python-common] [pkgtools/cwrappers]

Package options: fax

Master sites:

Filesize: 25074.46 KB

Version history: (Expand)


CVS history: (Expand)


   2022-03-15 03:30:23 by David H. Gutteridge | Files touched by this commit (1)
Log message:
hplip: add a comment explaining the qt5 option situation
   2022-03-13 06:49:15 by David H. Gutteridge | Files touched by this commit (1)
Log message:
hplip: sort PLIST.scan
   2022-03-13 06:46:56 by David H. Gutteridge | Files touched by this commit (8) | Package updated
Log message:
hplip: fix botched patches and qt5 option packaging

When some patches were last updated, some incorrect changes were
inadvertently added. This broke some of the functionality, since there
were hard-coded paths added (e.g., "/usr/pkg/bin/python3.7").

Also fix qt5 option packaging so this actually builds again. There are
still issues that need investigation, but at least an executable can
now run and be interacted with (e.g., attaching as a plugin in Xfce).
   2022-03-08 23:55:41 by David H. Gutteridge | Files touched by this commit (1)
Log message:
hplip: adjust a test condition for older NetBSD (NFC)

Avoid the upper limit of 9.x, since 10.x will be branched soon and, as
a bonus, simplify the statement.
   2021-12-08 17:07:18 by Adam Ciarcinski | Files touched by this commit (3063)
Log message:
revbump for icu and libffi
   2021-10-26 13:15:15 by Nia Alarie | Files touched by this commit (1670)
Log message:
print: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes
   2021-10-07 16:52:04 by Nia Alarie | Files touched by this commit (1670)
Log message:
print: Remove SHA1 hashes for distfiles
   2021-09-29 21:01:31 by Adam Ciarcinski | Files touched by this commit (872)
Log message:
revbump for boost-libs