./regress/print-plist-python, Test escaping in PRINT_PLIST_AWK

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.0nb3, Package name: print-plist-python-0.0nb3, Maintainer: pkgsrc-users

This test verifies that the dots that may appear as "3.7" in PYVERSSUFFIX
are properly escaped when that variable is treated as a regular
expression in PLIST_AWK.


Required to run:
[devel/py-setuptools] [lang/python37]

Required to build:
[pkgtools/cwrappers]

Version history: (Expand)


CVS history: (Expand)


   2022-06-30 13:19:02 by Nia Alarie | Files touched by this commit (524)
Log message:
*: Revbump packages that use Python at runtime without a PKGNAME prefix
   2022-01-04 21:55:40 by Thomas Klausner | Files touched by this commit (1595)
Log message:
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS
   2020-12-04 21:45:51 by Nia Alarie | Files touched by this commit (456)
Log message:
Revbump packages with a runtime Python dep but no version prefix.

For the Python 3.8 default switch.
   2019-07-17 20:34:16 by Roland Illig | Files touched by this commit (4)
Log message:
lang/python: fix PYVERSSUFFIX escaping for print-PLIST

Before, the filename "3270" was wrongly replaced with \ 
"${PYVERSSUFFIX}"
since the version number "3.7", when interpreted as a regular expression,
matched that filename.