./security/libykneomgr, Yubikey NEO C library and command-line tool

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.1.8nb1, Package name: libykneomgr-0.1.8nb1, Maintainer: pettai

This is a C library to interact with the CCID-part of the YubiKey
NEO. There is a command line tool "ykneomgr" for interactive use.
It supports querying the YubiKey NEO for firmware version, operation
mode (OTP/CCID) and serial number. You may also mode switch the
device and manage applets (list, delete and install).


Required to run:
[archivers/libzip] [security/pcsc-lite]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 5383c7849139a737f995a4f825de9b99aace0478
RMD160: 34c49ae3ad4d29ec85f935f9c274ea36c2ba98e5
Filesize: 611.579 KB

Version history: (Expand)


CVS history: (Expand)


   2020-05-22 12:56:49 by Adam Ciarcinski | Files touched by this commit (624)
Log message:
revbump after updating security/nettle
   2020-03-24 18:38:14 by Nia Alarie | Files touched by this commit (2) | Package updated
Log message:
libykneomgr: Update to 0.1.8

* Version 0.1.8 (released 2015-10-01)

** Add documentation for mode arguments.

** Don't treat applet selection error as a critical error.

* Version 0.1.7 (released 2015-04-09)

** Check programming sequence when changing mode.
   2020-03-08 17:51:54 by Thomas Klausner | Files touched by this commit (2833)
Log message:
*: recursive bump for libffi
   2020-01-18 22:51:16 by Jonathan Perkin | Files touched by this commit (1836)
Log message:
*: Recursive revision bump for openssl 1.1.1.
   2019-07-21 00:46:59 by Thomas Klausner | Files touched by this commit (595)
Log message:
*: recursive bump for nettle 3.5.1
   2018-04-18 00:29:53 by Thomas Klausner | Files touched by this commit (286)
Log message:
Add p11-kit to gnutls/bl3.mk and bump dependencies.
   2018-03-12 12:18:01 by Thomas Klausner | Files touched by this commit (2155)
Log message:
Recursive bumps for fontconfig and libzip dependency changes.
   2017-09-03 00:02:25 by Thomas Klausner | Files touched by this commit (13)
Log message:
Bump libzip ABI depends and PKGREVISIONs of its users for bzip2 dependency.