./time/py-goocalendar, Calendar widget using GooCanvas

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.7.0, Package name: py37-goocalendar-0.7.0, Maintainer: pkgsrc-users

A calendar widget for GTK using PyGoocanvas.


Required to run:
[devel/py-setuptools] [devel/py-gobject3] [graphics/goocanvas2] [lang/python37]

Required to build:
[pkgtools/x11-links] [x11/xcb-proto] [x11/fixesproto4] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

SHA1: c86583cabaae3d1b02850dabc4684b05d869207e
RMD160: 16a962ad1dfcc3398c03900ec8dbc2456d4c47c3
Filesize: 30.127 KB

Version history: (Expand)


CVS history: (Expand)


   2020-03-11 20:45:46 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
py-goocalendar: update to 0.7.0.

Version 0.7.0 - 2020-02-23
* Bug fixes (see mercurial logs for details)
* Use Gtk default font as font by default
* Manage non editable event
* Add support for Python 3.8
* Replace font-desc properties by font

Version 0.6 - 2019-10-05
* Add support for Python 3.7

Version 0.5 - 2019-03-22
* Use GTK+ 3
* Remove support for Python 2
* Add single day view

Version 0.4 - 2018-06-26
* Add support for Python 3

Version 0.3 - 2016-11-28
* Add support for goocanvas >= 2.0
* Add colors and font-desc properties to Calendar

Version 0.2 - 2015-02-11
* Bug fixes (see mercurial logs for details)
   2020-01-19 00:36:14 by Roland Illig | Files touched by this commit (3046)
Log message:
all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
   2019-11-02 17:28:42 by Roland Illig | Files touched by this commit (40)
Log message:
time: align variable assignments

pkglint -Wall -F --only aligned -r

No manual corrections.
   2019-09-02 15:20:22 by Adam Ciarcinski | Files touched by this commit (415)
Log message:
Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for \ 
future Python 3.8
   2019-04-26 15:14:25 by Maya Rashish | Files touched by this commit (473)
Log message:
Omit mentions of python 34 and 35, after those were removed.

- Includes some whitespace changes, to be handled in a separate commit.
   2018-07-03 07:03:44 by Adam Ciarcinski | Files touched by this commit (495)
Log message:
extend PYTHON_VERSIONS_ for Python 3.7
   2017-09-16 21:27:31 by Thomas Klausner | Files touched by this commit (372)
Log message:
Reset maintainer
   2017-09-04 20:55:10 by Thomas Klausner | Files touched by this commit (40) | Package updated
Log message:
Update some URLs.