./wip/libimobiledevice, Libraries and tools to communicate with iOS devices

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.2.0, Package name: libimobiledevice-1.2.0, Maintainer: cfkoch

libimobiledevice is a cross-platform software library that talks the
protocols to support iPhone, iPod Touch, iPad and Apple TV devices. Unlike
other projects, it does not depend on using any existing proprietary
libraries and does not require jailbreaking. It allows other software to
easily access the device's filesystem, retrieve information about the device
and it's internals, backup/restore the device, manage SpringBoard® icons,
manage installed applications, retrieve addressbook/calendars/notes and
bookmarks and (using libgpod) synchronize music and video to the device. The
library is in development since August 2007 with the goal to bring support
for these devices to the Linux Desktop.


Required to run:
[security/openssl] [textproc/libplist] [wip/libusbmuxd] [lang/python37]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: a8e3f21180b1d6df754d04a4080a29cf6891e701
RMD160: 0d1ec5a088abd73ac85c0c708524069cb22daf0f
Filesize: 616.694 KB

Version history: (Expand)