./wip/p5-Packager-Utils, Support packagers managing packages and upstream mapping

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 0.0nb20200102, Package name: p5-Packager-Utils-0.0nb20200102, Maintainer: sno

Support packagers managing packages and upstream mapping (update,
find, ...).


Required to run:
[www/p5-Template-Toolkit] [databases/p5-DBD-SQLite] [lang/perl5] [devel/p5-File-Find-Rule] [devel/p5-File-HomeDir] [devel/p5-List-MoreUtils] [devel/p5-Module-CoreList] [devel/p5-Module-Pluggable] [devel/p5-Carp-Assert] [databases/p5-SQL-Translator] [databases/p5-DBIx-Class] [devel/p5-Moose] [devel/p5-File-ShareDir] [devel/p5-CPAN-DistnameInfo] [devel/p5-Hash-MoreUtils] [devel/p5-IO-CaptureOutput] [devel/p5-File-pushd] [devel/p5-File-Find-Rule-Age] [devel/p5-MetaCPAN-API] [devel/p5-File-ShareDir-Install] [devel/p5-MooX-Cmd] [devel/p5-MooX-Options] [devel/p5-MooX-Roles-Pluggable] [devel/p5-Alien-Packages]

Required to build:
[devel/git-base] [pkgtools/cwrappers]

Version history: (Expand)


CVS history: (Expand)


   2015-07-12 20:57:34 by Thomas Klausner | Files touched by this commit (3)
Log message:
Comment out dependencies of the style
{perl>=5.16.6,p5-ExtUtils-ParseXS>=3.15}:../../devel/p5-ExtUtils-ParseXS
since pkgsrc enforces the newest perl version anyway, so they
should always pick perl, but sometimes (pkg_add) don't due to the
design of the {,} syntax.

No effective change for the above reason.

Ok joerg
   2014-08-13 10:27:23 by Thomas Klausner | Files touched by this commit (1)
Log message:
Upstream switched to MakeMaker. Add newly missing p5-File-ShareDir-Install
dependency.
   2014-05-31 13:54:57 by Thomas Klausner | Files touched by this commit (1)
Log message:
Use CPAN from perl.
   2013-12-04 21:28:05 by Thomas Klausner | Files touched by this commit (1)
Log message:
Add p5-Moose dependency.
   2013-12-01 00:27:08 by Thomas Klausner | Files touched by this commit (1)
Log message:
Add example config to PLIST.
   2013-12-01 00:26:37 by Thomas Klausner | Files touched by this commit (1)
Log message:
Install example config file.
   2013-11-30 23:40:50 by Thomas Klausner | Files touched by this commit (1)
Log message:
Depend on p5-Alien-Packages.
   2013-10-24 12:04:47 by Thomas Klausner | Files touched by this commit (1)
Log message:
Add missing dependency.