./wip/spade, SPADE is an agent platform based on the XMPP/Jabber technology

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.0rc4nb1, Package name: spade-2.0rc4nb1, Maintainer: jihbed.research

SPADE (Smart Python multi-Agent Development Environment) is a Multiagent and
Organizations Platform based on the XMPP/Jabber technology and written in the
Python programming language. This technology offers by itself many features and
facilities that ease the construction of MAS, such as an existing communication
channel, the concepts of users (agents) and servers (platforms) and an
extensible communication protocol based on XML, just like FIPA-ACL. Many other
agent platforms exist, but SPADE is the first to base its roots on
the XMPP technology

DEINSTALL [+/-]

Required to run:
[net/py-twisted] [net/py-dns] [security/py-m2crypto] [wip/py-event] [security/py-crypto] [math/py-gmpy] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 3de52a664ac33e71a8205aa61c5581fbe1039dba
RMD160: 8347ccb8d559e9a018548b82b3de06ee80a36504
Filesize: 538.198 KB

Version history: (Expand)


CVS history: (Expand)


   2014-05-09 09:38:42 by Thomas Klausner | Files touched by this commit (229)
Log message:
Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.
   2014-01-26 16:49:50 by Thomas Klausner | Files touched by this commit (121)
Log message:
Mark packages as not python-3.x ready where appropriate.
   2014-01-25 11:38:23 by Thomas Klausner | Files touched by this commit (28) | Package updated
Log message:
Mark packages as not ready for python-3.x where applicable;
either because they themselves are not ready or because a
dependency isn't. This is annotated by
PYTHON_VERSIONS_INCOMPATIBLE=  33 # not yet ported as of x.y.z
or
PYTHON_VERSIONS_INCOMPATIBLE=  33 # py-foo, py-bar
respectively, please use the same style for other packages,
and check during updates.

Use versioned_dependencies.mk where applicable.
Use REPLACE_PYTHON instead of handcoded alternatives, where applicable.
Reorder Makefile sections into standard order, where applicable.

Remove PYTHON_VERSIONS_INCLUDE_3X lines since that will be default
with the next commit.

Whitespace cleanups and other nits corrected, where necessary.
   2014-01-18 00:10:28 by Thomas Klausner | Files touched by this commit (4)
Log message:
Convert to versioned_dependencies.mk (for dns).
   2013-12-14 10:26:55 by OBATA Akio | Files touched by this commit (6)
Log message:
consider that py-crypto>=2.0 is sufficient for alternative of py-amkCrypto.
   2012-10-12 22:32:05 by Aleksej Saushev | Files touched by this commit (6)
Log message:
Drop dependency on lang/py-psyco.
It works only for Python 2.6 which is becoming obsolete in some time.
As such it doesn't fit well for packages that are going to enter pkgsrc in future.
   2012-10-07 18:23:08 by Aleksej Saushev | Files touched by this commit (87)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
Mark packages that don't or might probably not have staged installation.
   2012-10-04 00:14:51 by Thomas Klausner | Files touched by this commit (40) | Package updated
Log message:
Update for python25 removal.