./www/p5-Catalyst-Authentication-Credential-HTTP, HTTP Basic and Digest authentication for Catalyst

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.018nb2, Package name: p5-Catalyst-Authentication-Credential-HTTP-1.018nb2, Maintainer: pkgsrc-users

This module provides the feature of HTTP authentication for
Catalyst::Plugin::Authentication. Both basic and digest authentication
are currently supported.

When authentication is required, this module sets a status of 401, and
the body of the response to 'Authorization required.'. To override this
and set some own content, check for the $c->res->status == 401 in the
end action, and change the body accordingly.


Required to run:
[www/p5-URI] [lang/perl5] [devel/p5-Class-Accessor] [devel/p5-Data-UUID] [www/p5-Catalyst-Runtime] [www/p5-Catalyst-Plugin-Authentication] [devel/p5-String-Escape]

Required to build:
[devel/p5-Test-Exception] [devel/p5-Test-MockObject] [devel/p5-Package-DeprecationManager] [devel/p5-Module-Build-Tiny] [pkgtools/cwrappers] [devel/p5-Test-Needs]

Master sites: (Expand)

SHA1: bcaee841540a556697770909e000af770d544c1f
RMD160: 3c3d95a0ff1b981e8c6c53b50b650bc3adc406a7
Filesize: 39.02 KB

Version history: (Expand)


CVS history: (Expand)


   2019-11-04 23:10:16 by Roland Illig | Files touched by this commit (243)
Log message:
www: align variable assignments

pkglint -Wall -F --only aligned --only indent -r

Manually excluded phraseanet since pkglint got the indentation wrong.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2019-06-30 22:17:50 by Nia Alarie | Files touched by this commit (1816) | Package updated
Log message:
Update packages using a search.cpan.org HOMEPAGE to metacpan.org.

The former now redirects to the latter.

This covers the most simple cases where http://search.cpan.org/dist/name
can be changed to https://metacpan.org/release/name.

Reviewed by hand to hopefully make sure no unwanted changes sneak in.
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2017-09-27 08:57:36 by Thomas Klausner | Files touched by this commit (2) | Package updated
Log message:
p5-Catalyst-Authentication-Credential-HTTP: update to 1.018.

1.018     2017-06-28 00:28:23Z
   - removed optional prereqs from metadata (added in 1.017)

1.017     2017-06-27 23:20:58Z
   - modernized the tooling for 5.26 compatibility
   2017-06-28 15:24:29 by Jonathan Perkin | Files touched by this commit (11)
Log message:
These packages all require the PERL_USE_UNSAFE_INC hack.
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.