./www/p5-libapreq2, Lots of Apache specific httpd handling modules

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 2.13nb5, Package name: p5-ap24-libapreq2-2.13nb5, Maintainer: pkgsrc-users

This package contains modules for manipulating client request data via
the Apache API with Perl and C. Functionality includes:

- parsing of application/x-www-form-urlencoded data
- parsing of multipart/form-data
- parsing of HTTP Cookies


Required to run:
[www/ap2-perl] [lang/perl5] [devel/p5-ExtUtils-XSBuilder]

Required to build:
[www/apache24] [pkgtools/cwrappers]

Master sites: (Expand)

SHA1: db3761625a62230147896b47e9b047660b20ba28
RMD160: 8d7d2573624193b6dfbbe354b3771012257c1578
Filesize: 870.43 KB

Version history: (Expand)


CVS history: (Expand)


   2020-08-31 20:13:29 by Thomas Klausner | Files touched by this commit (3631) | Package updated
Log message:
*: bump PKGREVISION for perl-5.32.
   2020-03-22 22:21:05 by Roland Illig | Files touched by this commit (4)
Log message:
www/p5-libapreq2: remove ignored SUBST block

The file env/Makefile.in doesn't exist anymore, and the other Makefile.in
files don't run apxs anymore.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-07-04 15:40:45 by Jonathan Perkin | Files touched by this commit (423)
Log message:
*: Move SUBST_STAGE from post-patch to pre-configure

Performing substitutions during post-patch breaks tools such as mkpatches,
making it very difficult to regenerate correct patches after making changes,
and often leading to substituted string replacements being committed.
   2017-06-05 16:25:36 by Ryo ONODERA | Files touched by this commit (2298)
Log message:
Recursive revbump from lang/perl5 5.26.0
   2017-03-11 20:08:19 by Maya Rashish | Files touched by this commit (1)
Log message:
libapreq2: Embed apache version into PKGNAME.

This package has a dependency on an apache-versioned pkg (ap22-perl) and so
the binary package will only work for one version of apache, previously
apache22.

PR pkg/50583 from Randolf Richardson
   2016-06-08 21:25:20 by Thomas Klausner | Files touched by this commit (2236) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.