./x11/xlsclients, X client listing utility

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 1.1.4, Package name: xlsclients-1.1.4, Maintainer: joerg

This package provides xlsclients, a program to list client applications
running on a display.

This is from the modular X.org X11 project.


Required to run:
[x11/xcb-util] [x11/libxcb]

Required to build:
[x11/xcb-proto] [pkgtools/cwrappers] [x11/xorgproto]

Master sites:

Filesize: 127.525 KB

Version history: (Expand)


CVS history: (Expand)


   2021-10-26 13:35:01 by Nia Alarie | Files touched by this commit (674)
Log message:
x11: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes

Unfetchable distfiles (fetched conditionally?):
./x11/py-qt4/distinfo PyQt4_gpl_mac-4.12.3.tar.gz
   2021-10-07 17:14:47 by Nia Alarie | Files touched by this commit (675)
Log message:
x11: Remove SHA1 hashes for distfiles
   2020-01-19 00:36:14 by Roland Illig | Files touched by this commit (3046)
Log message:
all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
   2018-03-10 23:07:37 by Thomas Klausner | Files touched by this commit (3) | Package updated
Log message:
xlsclients: update to 1.1.4.

Alan Coopersmith (4):
      configure: Drop AM_MAINTAINER_MODE
      autogen.sh: Honor NOCONFIGURE=1
      Print which option was in error along with usage message
      xlsclients 1.1.4

Emil Velikov (1):
      autogen.sh: use quoted string variables

Mihail Konev (1):
      autogen: add default patch prefix

Peter Hutterer (1):
      autogen.sh: use exec instead of waiting for configure to finish
   2015-11-04 04:29:14 by Alistair G. Crooks | Files touched by this commit (670)
Log message:
Add SHA512 digests for distfiles for x11 category

Problems found locating distfiles:
        Package modular-xorg-server: missing distfile xorg-server-1.17.4.tar.bz2
        Package py-qt4: missing distfile PyQt-mac-gpl-4.11.1.tar.gz
        Package xservers: missing distfile xservers-3.3.6.5.tar.bz2
        Package xview-clients: missing distfile xview3.2p1-X11R6.tar.gz
        Package xview-lib: missing distfile xview3.2p1-X11R6.tar.gz

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2013-09-09 11:38:32 by Thomas Klausner | Files touched by this commit (2)
Log message:
Update to 1.1.3:

This minor maintenance release cleans up some compiler warnings,
improves the build configuration, and adds a -version option.

Alan Coopersmith (4):
      Give unique names to the two reply variables in child_info
      Add -version flag to print version from PACKAGE_STRING
      Fix deconstification warnings from gcc
      xlsclients 1.1.3

Gaetan Nadon (3):
      make: remove $(LIBOBJS) dead code
      Revert "make: remove $(LIBOBJS) dead code"
      configure.ac: regroup statements and comment
   2012-10-29 06:07:25 by Aleksej Saushev | Files touched by this commit (563)
Log message:
Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.
   2012-10-02 14:09:42 by Matthias Scheler | Files touched by this commit (19)
Log message:
Increase the minium required version of the "x11/libxcb" package to 1.6.
There are at least two packages ("graphics/cairo" and \ 
"x11/xlsclients")
which require this. And we definitely want to avoid the situation where
both the based and "pkgsrc" version get used at the same time.

Bump all the packages which use the "x11/libxcb" package except the two
which already require version 1.6. For those package remove the manually
set minimum required version.

Change discussed with Thomas Klausner in private e-mail.