./print/foomatic4-db-engine, Foomatics database engine

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.0.12nb4, Package name: foomatic-db-engine-4.0.12nb4, Maintainer: pkgsrc-users

Foomatic's database engine generates PPD files from the data in
Foomatic's XML database. It also contains scripts to directly generate
print queues and handle jobs.


Required to run:
[textproc/libxml2] [www/curl] [lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: c3b747113b6a64b998000774e7c2d03ce48654c1
RMD160: 163ad52e616928aa723cb3d263f1686e6a187500
Filesize: 352.05 KB

Version history: (Expand)


CVS history: (Expand)


   2017-01-01 17:06:40 by Adam Ciarcinski | Files touched by this commit (616) | Package updated
Log message:
Revbump after boost update
   2016-10-07 20:26:14 by Adam Ciarcinski | Files touched by this commit (611) | Package updated
Log message:
Revbump post boost update
   2016-07-09 08:39:18 by Thomas Klausner | Files touched by this commit (1068) | Package updated
Log message:
Bump PKGREVISION for perl-5.24.0 for everything mentioning perl.
   2016-03-05 12:29:49 by Jonathan Perkin | Files touched by this commit (1813) | Package updated
Log message:
Bump PKGREVISION for security/openssl ABI bump.
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2015-08-16 00:54:50 by Leonardo Taccari | Files touched by this commit (3) | Package updated
Log message:
Update print/foomatic4-db-engine to foomatic-db-engine-4.0.12.
ok wiz@.

pkgsrc changes:
 o Added LICENSE

Changes:
2014-11-14 Till Kamppeter <till.kamppeter@gmail.com>
	* foomatic-ppdfile.in: Foomatic doesn't provide some offered PPD
	  files. Thanks to Marek Kasik for the patch (bug #1238).

2014-08-22 Till Kamppeter <till.kamppeter@gmail.com>
	* foomatic-ppd-to-xml.in: Let missing XML files be added when to a
	  PPD with already existing XML files new "*Product:" lines get
	  added.

2014-03-20 Till Kamppeter <till.kamppeter@gmail.com>
	* Tagged branch for release 4.0.11.
	* README, USAGE, configure.ac: Updated for release 4.0.11.
	* lib/Foomatic/DB.pm: Do not interpret option default values set to
	  "0" in PPD files as no default setting defined. Thanks to Deng
	  Pang from Ricoh (DengPang at rst dot ricoh dot com) for the report.

2014-02-18 Till Kamppeter <till.kamppeter@gmail.com>
	* Tagged branch for release 4.0.10.
	* README, USAGE, configure.ac: Updated for release 4.0.10.

2014-01-02 Till Kamppeter <till.kamppeter@gmail.com>
	* foomatic-addpjloptions.in: Make foomatic-addpjloptions work with
	  the system's Foomatic database, too.
   2015-06-12 12:52:19 by Thomas Klausner | Files touched by this commit (3152)
Log message:
Recursive PKGREVISION bump for all packages mentioning 'perl',
having a PKGNAME of p5-*, or depending such a package,
for perl-5.22.0.
   2014-09-25 19:37:55 by Jonathan Perkin | Files touched by this commit (1)
Log message:
Fix TOOLS_DIR reference in installed file.