./print/foomatic4-db-engine, Foomatics database engine

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 4.0.13nb3, Package name: foomatic-db-engine-4.0.13nb3, Maintainer: pkgsrc-users

Foomatic's database engine generates PPD files from the data in
Foomatic's XML database. It also contains scripts to directly generate
print queues and handle jobs.


Required to run:
[textproc/libxml2] [www/curl] [lang/perl5]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 68d6addec5ac5ba4235b5da991351eab5c754df5
RMD160: 77b92e8849bfe09d46ab66900aaad3dae61060bd
Filesize: 352.179 KB

Version history: (Expand)


CVS history: (Expand)


   2020-06-02 10:25:05 by Adam Ciarcinski | Files touched by this commit (1689)
Log message:
Revbump for icu
   2020-05-01 23:07:24 by Roland Illig | Files touched by this commit (1)
Log message:
print/foomatic4-db-engine: allow SUBST block to be a no-op
   2020-01-19 00:36:14 by Roland Illig | Files touched by this commit (3046)
Log message:
all: migrate several HOMEPAGEs to https

pkglint --only "https instead of http" -r -F

With manual adjustments afterwards since pkglint 19.4.4 fixed a few
indentations in unrelated lines.

This mainly affects projects hosted at SourceForce, as well as
freedesktop.org, CTAN and GNU.
   2019-08-11 15:25:21 by Thomas Klausner | Files touched by this commit (3557) | Package updated
Log message:
Bump PKGREVISIONs for perl 5.30.0
   2018-08-22 11:48:07 by Thomas Klausner | Files touched by this commit (3558)
Log message:
Recursive bump for perl5-5.28.0
   2018-07-21 18:07:22 by Leonardo Taccari | Files touched by this commit (2) | Package updated
Log message:
foomatic4-db-engine: Update to 4.0.13

pkgsrc changes:
 - Try to address several pkglint warnings
 - Also pass CUPS_PPDS via CONFIGURE_ENV
 - Depends on curl via DEPENDS: just bin/curl is needed not libcurl

Changes:
4.0.13
------
 * Makefile.in: Add support for LDFLAGS variable (bug 1422).
 * configure.ac: Allow user-configurable PERLPREFIX via environment
   variable (Bug 1294).
   2018-07-20 21:14:00 by Leonardo Taccari | Files touched by this commit (3)
Log message:
foomatic4-db-engine: Avoid possible strcpy(3) undefined behaviour

When *dst and *src overlaps in strcpy(3) according to POSIX the behaviour is
undefined and at least on NetBSD this lead to SIGABRT (due buffer overflow
detection of fortify) in foomatic-combo-xml.

PKGREVISION++
   2018-04-29 23:32:09 by Adam Ciarcinski | Files touched by this commit (629) | Package updated
Log message:
revbump for boost-libs update