./print/py-pisa, HTML2pdf converter (obsolete, use print/py-weasyprint instead)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.0.33nb1, Package name: py27-pisa-3.0.33nb1, Maintainer: joerg

pisa is a html2pdf convert using ReportLab, HTML5lib and pyPDF.
It supports HTML 5 and CSS 2.1.

This package is obsolete. Please use print/py-weasyprint instead.


Required to run:
[print/py-reportlab] [devel/py-setuptools] [textproc/py-html5lib] [print/py-Pdf] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

SHA1: 3d7e644b96b7c8f98bfd5823a163c3badd662209
RMD160: 1479865d1f0b14f4a37c74fc8aae7e72e9d0efac
Filesize: 4395.073 KB

Version history: (Expand)


CVS history: (Expand)


   2017-01-01 15:44:09 by Thomas Klausner | Files touched by this commit (577)
Log message:
Add python-3.6 to incompatible versions.
   2016-11-11 13:47:53 by Joerg Sonnenberger | Files touched by this commit (3)
Log message:
Fix reportlab version check for 3.x and later.
   2016-11-08 12:42:01 by Thomas Klausner | Files touched by this commit (5)
Log message:
Re-import py27-pisa-3.0.33 as print/py-pisa as requested by joerg.

pisa is a html2pdf convert using ReportLab, HTML5lib and pyPDF.
It supports HTML 5 and CSS 2.1.

This package is obsolete. Please use print/py-weasyprint instead.
   2016-07-09 15:04:18 by Thomas Klausner | Files touched by this commit (599)
Log message:
Remove python33: adapt all packages that refer to it.
   2016-06-08 19:43:49 by Thomas Klausner | Files touched by this commit (356)
Log message:
Switch to MASTER_SITES_PYPI.
   2015-12-05 22:26:09 by Adam Ciarcinski | Files touched by this commit (578)
Log message:
Extend PYTHON_VERSIONS_INCOMPATIBLE to 35
   2015-11-04 02:03:03 by Alistair G. Crooks | Files touched by this commit (1194)
Log message:
Add SHA512 digests for distfiles for print category

Problems found locating distfiles:
	Package acroread7: missing distfile AdobeReader_enu-7.0.9-1.i386.tar.gz
	Package acroread8: missing distfile AdobeReader_enu-8.1.7-1.sparc.tar.gz
	Package cups-filters: missing distfile cups-filters-1.1.0.tar.xz
	Package dvidvi: missing distfile dvidvi-1.0.tar.gz
	Package lgrind: missing distfile lgrind.tar.bz2

Otherwise, existing SHA1 digests verified and found to be the same on
the machine holding the existing distfiles (morden).  All existing
SHA1 digests retained for now as an audit trail.
   2014-05-09 09:37:28 by Thomas Klausner | Files touched by this commit (553)
Log message:
Mark packages that are not ready for python-3.3 also not ready for 3.4,
until proven otherwise.