./print/py-pisa, HTML2pdf converter (obsolete, use print/py-weasyprint instead)

[ CVSweb ] [ Homepage ] [ RSS ] [ Required by ] [ Add to tracker ]


Branch: CURRENT, Version: 3.0.33nb5, Package name: py27-pisa-3.0.33nb5, Maintainer: joerg

pisa is a html2pdf convert using ReportLab, HTML5lib and pyPDF.
It supports HTML 5 and CSS 2.1.

This package is obsolete. Please use print/py-weasyprint instead.


Required to run:
[print/py-reportlab] [devel/py-setuptools] [textproc/py-html5lib] [print/py-Pdf] [lang/python27]

Required to build:
[pkgtools/cwrappers]

Master sites:

Filesize: 4395.073 KB

Version history: (Expand)


CVS history: (Expand)


   2022-06-22 00:18:16 by Joerg Sonnenberger | Files touched by this commit (1)
Log message:
Use regular py-reportlab again now that it works with 2.7 again.
   2022-01-05 21:07:11 by Thomas Klausner | Files touched by this commit (10)
Log message:
*: set USE_PKG_RESOURCES for some more packages
   2022-01-04 21:55:40 by Thomas Klausner | Files touched by this commit (1595)
Log message:
*: bump PKGREVISION for egg.mk users

They now have a tool dependency on py-setuptools instead of a DEPENDS
   2021-10-26 13:15:15 by Nia Alarie | Files touched by this commit (1670)
Log message:
print: Replace RMD160 checksums with BLAKE2s checksums

All checksums have been double-checked against existing RMD160 and
SHA512 hashes
   2021-10-07 16:52:04 by Nia Alarie | Files touched by this commit (1670)
Log message:
print: Remove SHA1 hashes for distfiles
   2021-04-29 15:10:41 by Joerg Sonnenberger | Files touched by this commit (1)
Log message:
Use py27 version of reportlab.
   2021-04-29 09:39:24 by Thomas Klausner | Files touched by this commit (1)
Log message:
py-pisa: mark as broken since it needs python 2.7

py-reportlab does not support py27 any longer.
   2019-09-02 15:20:22 by Adam Ciarcinski | Files touched by this commit (415)
Log message:
Changed PYTHON_VERSIONS_INCOMPATIBLE to PYTHON_VERSIONS_ACCEPTED; needed for \ 
future Python 3.8